summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-11-21 19:21:14 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-11-21 19:21:14 +0100
commit43ca4589c89747546aa10e0d60b874d45fb1d3af (patch)
tree612b4090d902ba2ef7af64ef571a5e53626e218a /dev-ada
parentdev-ada/gnatmem: drop gnat_2020 support (diff)
downloadgentoo-43ca4589c89747546aa10e0d60b874d45fb1d3af.tar.gz
gentoo-43ca4589c89747546aa10e0d60b874d45fb1d3af.tar.bz2
gentoo-43ca4589c89747546aa10e0d60b874d45fb1d3af.zip
dev-ada/libgpr: drop 2021-r1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/libgpr/libgpr-2021-r1.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-ada/libgpr/libgpr-2021-r1.ebuild b/dev-ada/libgpr/libgpr-2021-r1.ebuild
deleted file mode 100644
index d38fb37fd3e5..000000000000
--- a/dev-ada/libgpr/libgpr-2021-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ADA_COMPAT=( gnat_2021 gcc_12_2_0 )
-inherit ada multiprocessing
-
-MYP=gprbuild-${PV}-${PV}0519-19A34-src
-ID=23a77a37247ff811609e23a0a271f445c299fc8f
-ADAMIRROR=https://community.download.adacore.com/v1
-
-DESCRIPTION="Ada library to handle GPRbuild project files"
-HOMEPAGE="http://libre.adacore.com/"
-SRC_URI="${ADAMIRROR}/${ID}?filename=${MYP}.tar.gz -> ${MYP}.tar.gz"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+shared static-libs static-pic"
-
-RDEPEND="dev-ada/xmlada[shared?,static-libs?,static-pic?,${ADA_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-ada/gprbuild[${ADA_USEDEP}]"
-REQUIRED_USE="${ADA_REQUIRED_USE}
- || ( shared static-libs static-pic )"
-
-S="${WORKDIR}"/${MYP}
-
-PATCHES=( "${FILESDIR}"/${PN}-2020-gentoo.patch )
-
-src_prepare() {
- default
- sed -i -e '/Library_Name/s|gpr|gnatgpr|' gpr/gpr.gpr || die
-}
-
-src_configure() {
- emake setup
-}
-
-src_compile() {
- build () {
- gprbuild -p -m -j$(makeopts_jobs) -XBUILD=production -v \
- -XLIBRARY_TYPE=$1 -XXMLADA_BUILD=$1 \
- gpr/gpr.gpr -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS} || die
- }
- if use shared; then
- build relocatable
- fi
- if use static-libs; then
- build static
- fi
- if use static-pic; then
- build static-pic
- fi
-}
-
-src_install() {
- if use static-libs; then
- emake prefix="${D}"/usr libgpr.install.static
- fi
- for kind in shared static-pic; do
- if use ${kind}; then
- emake prefix="${D}"/usr libgpr.install.${kind}
- fi
- done
- rm -r "${D}"/usr/share/gpr/manifests || die
- einstalldocs
-}