summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 17:30:23 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:40 +0200
commit418d3ab7f8eae31dd6edee5b6eb8730f4c9ea031 (patch)
tree9c2743f5e7b5affc1778af279e8d796c96549b6e /app-vim/locateopen/locateopen-1.3-r2.ebuild
parentapp-vim/languagetool: EAPI8 bump (diff)
downloadgentoo-418d3ab7f8eae31dd6edee5b6eb8730f4c9ea031.tar.gz
gentoo-418d3ab7f8eae31dd6edee5b6eb8730f4c9ea031.tar.bz2
gentoo-418d3ab7f8eae31dd6edee5b6eb8730f4c9ea031.zip
app-vim/locateopen: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-vim/locateopen/locateopen-1.3-r2.ebuild')
-rw-r--r--app-vim/locateopen/locateopen-1.3-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/locateopen/locateopen-1.3-r2.ebuild b/app-vim/locateopen/locateopen-1.3-r2.ebuild
new file mode 100644
index 000000000000..620fa6113d63
--- /dev/null
+++ b/app-vim/locateopen/locateopen-1.3-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: open a file without supplying a path"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=858"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="sys-apps/mlocate"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides commands that hook vim into mlocate:
+\ :LocateEdit filename
+\ :LocateSplit filename
+\ :LocateSource filename
+\ :LocateRead filename
+To configure:
+\ :let g:locateopen_ignorecase = 1 \" enable ignore case mode
+\ :let g:locateopen_smartcase = 0 \" disable smart case mode
+\ :let g:locateopen_alwaysprompt = 1 \" show menu for one match"