summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/enhancedcommentify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/enhancedcommentify')
-rw-r--r--app-vim/enhancedcommentify/Manifest1
-rw-r--r--app-vim/enhancedcommentify/enhancedcommentify-2.3.ebuild26
-rw-r--r--app-vim/enhancedcommentify/files/enhancedcommentify-2.1-extra-ft-support.patch13
-rw-r--r--app-vim/enhancedcommentify/files/enhancedcommentify-2.1-gentooisms.patch23
-rw-r--r--app-vim/enhancedcommentify/metadata.xml5
5 files changed, 68 insertions, 0 deletions
diff --git a/app-vim/enhancedcommentify/Manifest b/app-vim/enhancedcommentify/Manifest
new file mode 100644
index 000000000000..2c333bb0e72d
--- /dev/null
+++ b/app-vim/enhancedcommentify/Manifest
@@ -0,0 +1 @@
+DIST enhancedcommentify-2.3.tar.bz2 17005 SHA256 38ed6366a9b1d77320514df48c6a86b2a80552cc7d7fba29fa46f3d1abbfec10 SHA512 673cb42fcc5a2d23ae404bbfa4664f388901249d3ed8315f77227f3fa42f3c267d69eda7554347b4e70de81c9bd58437c243a42d62218444063d5235fe22a171 WHIRLPOOL ac46f5a371dedc0ab1997b60f7832b10d6068c8926d1ecf3d3e01894e5097b28050e81745aa0153844e23859bb2d12aca664e87ab81dcd64199aed51fef42956
diff --git a/app-vim/enhancedcommentify/enhancedcommentify-2.3.ebuild b/app-vim/enhancedcommentify/enhancedcommentify-2.3.ebuild
new file mode 100644
index 000000000000..c89489fa3781
--- /dev/null
+++ b/app-vim/enhancedcommentify/enhancedcommentify-2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: enhanced comment creation"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=23"
+
+LICENSE="BSD"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="EnhancedCommentify"
+
+DEPEND="${DEPEND} >=sys-apps/sed-4"
+# bug #74897
+RDEPEND="!app-vim/ctx"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # gentooy things, bug #79185
+ epatch "${FILESDIR}"/${PN}-2.1-gentooisms.patch
+ epatch "${FILESDIR}"/${PN}-2.1-extra-ft-support.patch
+}
diff --git a/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-extra-ft-support.patch b/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-extra-ft-support.patch
new file mode 100644
index 000000000000..597518a6d547
--- /dev/null
+++ b/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-extra-ft-support.patch
@@ -0,0 +1,13 @@
+--- plugin/EnhancedCommentify.vim.orig 2005-03-01 02:28:23.409962824 -0500
++++ plugin/EnhancedCommentify.vim 2005-03-01 02:29:45.695453528 -0500
+@@ -740,7 +740,9 @@
+ \ 'psf\|ptcap\|r\|radiance\|ratpoison\|readline\remind\|'.
+ \ 'ruby\|screen\|sed\|sm\|snnsnet\|snnspat\|snnsres\|spec\|'.
+ \ 'squid\|terminfo\|tidy\|tli\|tsscl\|vgrindefs\|vrml\|'.
+- \ 'wget\|wml\|xf86conf\|xmath\)$'
++ \ 'wget\|wml\|xf86conf\|xmath\|fstab\|apache\|resolv\|sudoers\|'.
++ \ 'ntp\|mailcap\|ssh_config\|sshdconfig\|mplayerconf\|desktop\|'.
++ \ 'gkrellmrc\|pf\|ipfilter\|grub\|fluxbox\)$'
+ let b:ECcommentOpen = '#'
+ let b:ECcommentClose = ''
+ elseif fileType =~ 'gentoo'
diff --git a/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-gentooisms.patch b/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-gentooisms.patch
new file mode 100644
index 000000000000..9e45142ff8ae
--- /dev/null
+++ b/app-vim/enhancedcommentify/files/enhancedcommentify-2.1-gentooisms.patch
@@ -0,0 +1,23 @@
+--- plugin/EnhancedCommentify.vim.orig 2005-01-27 00:20:00.049461056 -0500
++++ plugin/EnhancedCommentify.vim 2005-01-27 00:17:57.617073608 -0500
+@@ -628,6 +628,10 @@
+ " letter.
+ if match(synFiletype, '\l\+\u') == 0
+ let ft = substitute(synFiletype, '^\(\l\+\)\u.*$', '\1', "")
++ " work-around for gentoo-syntax stuff ; won't work with the above
++ " case, since all the identifiers start with a capital 'G'
++ elseif synFiletype =~ "GentooPackage*"
++ let ft = "gentoo"
+ endif
+
+ if ft == ""
+@@ -739,6 +743,9 @@
+ \ 'wget\|wml\|xf86conf\|xmath\)$'
+ let b:ECcommentOpen = '#'
+ let b:ECcommentClose = ''
++ elseif fileType =~ 'gentoo'
++ let b:ECcommentOpen = '#'
++ let b:ECcommentClose = ''
+ elseif fileType == 'webmacro'
+ let b:ECcommentOpen = '##'
+ let b:ECcommentClose = ''
diff --git a/app-vim/enhancedcommentify/metadata.xml b/app-vim/enhancedcommentify/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/enhancedcommentify/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>