summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-07-22 00:48:20 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-07-22 00:48:40 -0400
commitefeb61a41c447887122bfc899f634f434b19ed2c (patch)
tree7d831be6776b8e47c1e4be9f32f40f051f245752 /app-text
parentdev-util/ruff: add 0.5.4 (diff)
downloadgentoo-efeb61a41c447887122bfc899f634f434b19ed2c.tar.gz
gentoo-efeb61a41c447887122bfc899f634f434b19ed2c.tar.bz2
gentoo-efeb61a41c447887122bfc899f634f434b19ed2c.zip
app-text/calibre: add 7.15.0
Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/calibre/Manifest2
-rw-r--r--app-text/calibre/calibre-7.15.0.ebuild243
2 files changed, 245 insertions, 0 deletions
diff --git a/app-text/calibre/Manifest b/app-text/calibre/Manifest
index 2b375f20bf2d..4a6298c2b950 100644
--- a/app-text/calibre/Manifest
+++ b/app-text/calibre/Manifest
@@ -10,3 +10,5 @@ DIST calibre-7.13.0.tar.xz 44331860 BLAKE2B d5d9d04740dff52e59af0efff30e1044d52d
DIST calibre-7.13.0.tar.xz.sig 566 BLAKE2B 40ee9d53eb658623f0047601ddf26bde232b9f4575309faa09ab2ea74b70d8c43fa82a7dc80bb322fca908923661ed8ec33050917196c0f22ff490f9348b266f SHA512 6943ea01c30c8c2ed49f115873cbe1d75484a79deedf734d77ba2326b6f2a2d35994b0219d8e81789e46e8a56d01a19efe8f124c8ebb546b86fa287d8449bf6e
DIST calibre-7.14.0.tar.xz 44318744 BLAKE2B 3ade17216f3e79440cb113754c54295c3b0c2d09186300475c73d06d5cd592fa3962250ccafb9a26adb63d248f182e8da7c83415e38c506e36e327697aa5bc60 SHA512 718e83f9c11fd9e6a75cb2cee7172bf434ed642fc1e0db23ac6a7a1c7b01264fcd7f8840c12cb5f8184cc31c25c79f0d87255d8e1441b4cffaa9c88e90d4a663
DIST calibre-7.14.0.tar.xz.sig 566 BLAKE2B 79dad9f35bbd1bc6d06aa8e5cd1a9f9f4ab40f4044795bf285e81b0db02f36e6a1583726ae573c8d43a51577c6e55c96b9a59a0a94d223f4bb7e4d382dfb95d5 SHA512 25ea452efbef8f47498e75ed0485489bd5c97dfbcb6246ec19d5e7ec3b78aa5fad6f8ffac873fdc36f650c755e8011779a3cc326f719e88ad96697d19a7f2cc0
+DIST calibre-7.15.0.tar.xz 44384628 BLAKE2B f55a60107f87d8dd6b5cc95f77807906222680e0ff6ac2c7dd70b652f2a1fa58ae87f9f1a531a6124ea5f277507d2b2aadfedb6eda8fc489f9fa0d32b132a091 SHA512 80f11ab87bf1f370bc9f7c04e968d430dac44d026ebcc79191e73897e5b5d93be74b62cc71ed05b105caff871cd49a34d9b61337264170dcbac7266b0e4d6747
+DIST calibre-7.15.0.tar.xz.sig 566 BLAKE2B d6933235d401700d2cfe5e37a4ddacc5bb02d49aa199f4464fd29d93e210ecebaa10cf465f772a4f0d8029f517b6baad70249bb250dd43119d6fc7d869a4eabe SHA512 e336c2fe90c4ee0e243bbb105cc47a8092fac49d409f30c5a44a0f08cf951864febad3030feba3fad2de48a630e2934c7ecc0869fc49cda1fda3b056312b5520
diff --git a/app-text/calibre/calibre-7.15.0.ebuild b/app-text/calibre/calibre-7.15.0.ebuild
new file mode 100644
index 000000000000..e42daca289d1
--- /dev/null
+++ b/app-text/calibre/calibre-7.15.0.ebuild
@@ -0,0 +1,243 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite,ssl"
+
+inherit edo toolchain-funcs python-single-r1 qmake-utils verify-sig xdg
+
+DESCRIPTION="Ebook management application"
+HOMEPAGE="https://calibre-ebook.com/"
+SRC_URI="
+ https://download.calibre-ebook.com/${PV}/${P}.tar.xz
+ verify-sig? ( https://calibre-ebook.com/signatures/${P}.tar.xz.sig )
+"
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/kovidgoyal.gpg
+
+LICENSE="
+ GPL-3+
+ GPL-3
+ GPL-2+
+ GPL-2
+ GPL-1+
+ LGPL-3+
+ LGPL-2.1+
+ LGPL-2.1
+ BSD
+ MIT
+ Old-MIT
+ Apache-2.0
+ public-domain
+ || ( Artistic GPL-1+ )
+ CC-BY-3.0
+ OFL-1.1
+ PSF-2
+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="+font-subsetting ios speech +system-mathjax test +udisks unrar"
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Qt slotted dependencies are used because the libheadless.so plugin links to
+# QT_*_PRIVATE_ABI. It only uses core/gui/dbus.
+COMMON_DEPEND="${PYTHON_DEPS}
+ app-i18n/uchardet
+ >=app-text/hunspell-1.7:=
+ >=app-text/podofo-0.10.0:=
+ app-text/poppler[utils]
+ dev-libs/hyphen:=
+ >=dev-libs/icu-57.1:=
+ dev-libs/openssl:=
+ dev-libs/snowball-stemmer:=
+ $(python_gen_cond_dep '
+ >=dev-python/apsw-3.25.2_p1[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ >=dev-python/css-parser-1.0.4[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-5.2.1[${PYTHON_USEDEP}]
+ >=dev-python/html2text-2019.8.11[${PYTHON_USEDEP}]
+ >=dev-python/html5-parser-0.4.9[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.8.0[${PYTHON_USEDEP}]
+ dev-python/lxml-html-clean[${PYTHON_USEDEP}]
+ >=dev-python/markdown-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/mechanize-0.3.5[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.5[${PYTHON_USEDEP}]
+ >=dev-python/pillow-3.2.0[jpeg,truetype,webp,zlib,${PYTHON_USEDEP}]
+ >=dev-python/psutil-4.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pychm-0.8.6[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.5.3[${PYTHON_USEDEP}]
+ dev-python/PyQt6[gui,network,opengl,printsupport,quick,svg,widgets,${PYTHON_USEDEP}]
+ dev-python/PyQt6-WebEngine[widgets,${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.75.0[${PYTHON_USEDEP}]
+ ')
+ dev-qt/qtbase:6=[gui,widgets]
+ dev-qt/qtimageformats:6
+ dev-util/desktop-file-utils
+ dev-util/gtk-update-icon-cache
+ media-fonts/liberation-fonts
+ media-libs/fontconfig:=
+ >=media-libs/freetype-2:=
+ >=media-libs/libmtp-1.1.11:=
+ >=media-gfx/optipng-0.7.6
+ virtual/libusb:1=
+ x11-misc/shared-mime-info
+ >=x11-misc/xdg-utils-1.0.2-r2
+ font-subsetting? ( $(python_gen_cond_dep 'dev-python/fonttools[${PYTHON_USEDEP}]') )
+ ios? (
+ >=app-pda/usbmuxd-1.0.8
+ >=app-pda/libimobiledevice-1.2.0
+ )
+ speech? ( $(python_gen_cond_dep 'app-accessibility/speech-dispatcher[python,${PYTHON_USEDEP}]') )
+ system-mathjax? ( >=dev-libs/mathjax-3:= )
+ udisks? ( virtual/libudev )
+ unrar? ( dev-python/unrardll )
+"
+RDEPEND="${COMMON_DEPEND}
+ udisks? ( sys-fs/udisks:2 )"
+DEPEND="${COMMON_DEPEND}
+ test? ( $(python_gen_cond_dep '>=dev-python/chardet-3.0.3[${PYTHON_USEDEP}]') )
+"
+BDEPEND="$(python_gen_cond_dep '
+ >=dev-python/PyQt-builder-1.10.3[${PYTHON_USEDEP}]
+ >=dev-python/sip-5[${PYTHON_USEDEP}]
+ ')
+ virtual/pkgconfig
+ system-mathjax? ( dev-lang/rapydscript-ng )
+ verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )
+"
+
+PATCHES=(
+ # Skip calling a binary (JxrDecApp) from libjxr which is used for tests
+ # We don't (yet?) package libjxr and it seems to be dead upstream
+ # (last commit in 2017)
+ "${FILESDIR}/${PN}-7.0.0-jxr-test.patch"
+)
+
+src_prepare() {
+ default
+
+ # Warning:
+ #
+ # While it might be rather tempting to add yet another sed here,
+ # please don't. There have been several bugs in Gentoo's packaging
+ # of calibre from seds-which-become-stale. Please consider
+ # creating a patch instead, but in any case, run the test suite
+ # and ensure it passes.
+ #
+ # If in doubt about a problem, checking Fedora's packaging is recommended.
+
+ # Disable unnecessary privilege dropping for bug #287067.
+ sed -e "s:if os.geteuid() == 0:if False and os.geteuid() == 0:" \
+ -i setup/install.py || die "sed failed to patch install.py"
+
+ # This is only ever used at build time. It contains a small embedded copy
+ # of the rapydscript-ng compiler usable inside of qtwebengine, if you don't
+ # have rapydscript-ng (a nodejs package) itself installed. Its only purpose
+ # is to build some resources that come bundled in dist tarballs already...
+ # and which we may also need to regenerate e.g. to use system-mathjax.
+ #
+ # However, running qtwebengine violates the portage sandbox (among other
+ # things, it tries to create directories in /usr! amazing) so this is a
+ # wash anyway. The only real solution here is to package rapydscript-ng.
+ #
+ # We do not need it at build time, and *no one* needs it at install time.
+ # Delete the cruft.
+ rm -r resources/rapydscript/ || die
+}
+
+src_compile() {
+ # TODO: get qmake called by setup.py to respect CC and CXX too
+ tc-export CC CXX
+
+ # bug 821871
+ local MY_LIBDIR="${ESYSROOT}/usr/$(get_libdir)"
+ export FT_LIB_DIR="${MY_LIBDIR}" HUNSPELL_LIB_DIR="${MY_LIBDIR}" PODOFO_LIB_DIR="${MY_LIBDIR}"
+ export QMAKE="$(qt6_get_bindir)/qmake"
+
+ edo ${EPYTHON} setup.py build
+ edo ${EPYTHON} setup.py gui
+
+ # A few different resources are bundled in the distfile by default, because
+ # not all systems necessarily have them. We un-vendor them, using the
+ # upstream integrated approach if possible. See setup/revendor.py and
+ # consider migrating other resources to this if they do not use it, in
+ # *preference* over manual rm'ing.
+ edo ${EPYTHON} setup.py liberation_fonts \
+ --path-to-liberation_fonts "${EPREFIX}"/usr/share/fonts/liberation-fonts \
+ --system-liberation_fonts
+ if use system-mathjax; then
+ edo ${EPYTHON} setup.py mathjax --path-to-mathjax "${EPREFIX}"/usr/share/mathjax --system-mathjax
+ edo ${EPYTHON} setup.py rapydscript
+ fi
+}
+
+src_test() {
+ # Skipped tests:
+ local _test_excludes=(
+ # unpackaged Python dependency: py7zr
+ 7z
+ # unpackaged Python dependency: pyzstd
+ test_zstd
+ # tests if a completely unused module is bundled
+ pycryptodome
+
+ $(usev !speech speech_dispatcher)
+ $(usev !unrar test_unrar)
+
+ # undocumented reasons
+ test_mem_leaks
+ test_searching
+ )
+
+ edo ${PYTHON} setup.py test "${_test_excludes[@]/#/--exclude-test-name=}"
+}
+
+src_install() {
+ # Bug #352625 - Some LANGUAGE values can trigger the following ValueError:
+ # File "/usr/lib/python2.6/locale.py", line 486, in getdefaultlocale
+ # return _parse_localename(localename)
+ # File "/usr/lib/python2.6/locale.py", line 418, in _parse_localename
+ # raise ValueError, 'unknown locale: %s' % localename
+ #ValueError: unknown locale: 46
+ export -n LANG LANGUAGE ${!LC_*}
+ export LC_ALL=C.utf8 # bug #709682
+
+ # Bug #295672 - Avoid sandbox violation in ~/.config by forcing
+ # variables to point to our fake temporary $HOME.
+ export HOME="${T}/fake_homedir"
+ export CALIBRE_CONFIG_DIRECTORY="${HOME}/.config/calibre"
+ mkdir -p "${CALIBRE_CONFIG_DIRECTORY}" || die
+
+ addpredict /dev/dri #665310
+
+ # If this directory doesn't exist, zsh completion won't install
+ dodir /usr/share/zsh/site-functions
+
+ edo "${PYTHON}" setup.py install \
+ --staging-root="${ED}/usr" \
+ --prefix="${EPREFIX}/usr" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --staging-libdir="${ED}/usr/$(get_libdir)" \
+ --system-plugins-location="${EPREFIX}/usr/share/calibre/system-plugins"
+
+ cp -r man-pages/ "${ED}"/usr/share/man || die
+
+ find "${ED}"/usr/share -type d -empty -delete || die
+
+ python_fix_shebang "${ED}/usr/bin"
+
+ python_optimize "${ED}"/usr/$(get_libdir)/calibre "${D}/$(python_get_sitedir)"
+
+ newinitd "${FILESDIR}"/calibre-server-3.init calibre-server
+ newconfd "${FILESDIR}"/calibre-server-3.conf calibre-server
+}