summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-10 12:31:17 +0100
committerSam James <sam@gentoo.org>2022-07-10 12:32:03 +0100
commitd07024cc1ace6e153a00ac17012a71504d838c39 (patch)
treee5e1d4184a538b46d3be3551869c6f65b66efba8 /app-text
parentnet-misc/felix: fix UnusedInherits (diff)
downloadgentoo-d07024cc1ace6e153a00ac17012a71504d838c39.tar.gz
gentoo-d07024cc1ace6e153a00ac17012a71504d838c39.tar.bz2
gentoo-d07024cc1ace6e153a00ac17012a71504d838c39.zip
app-text/wdiff: EAPI 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/wdiff/wdiff-1.2.2-r2.ebuild (renamed from app-text/wdiff/wdiff-1.2.2-r1.ebuild)15
1 files changed, 9 insertions, 6 deletions
diff --git a/app-text/wdiff/wdiff-1.2.2-r1.ebuild b/app-text/wdiff/wdiff-1.2.2-r2.ebuild
index 9f0af0d46f14..4418e21d3f05 100644
--- a/app-text/wdiff/wdiff-1.2.2-r1.ebuild
+++ b/app-text/wdiff/wdiff-1.2.2-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Create a diff disregarding formatting"
HOMEPAGE="https://www.gnu.org/software/wdiff/"
@@ -16,14 +16,16 @@ RESTRICT="!test? ( test )"
RDEPEND="
sys-apps/diffutils
sys-apps/less
- sys-libs/ncurses:0="
-DEPEND="${RDEPEND}
+ sys-libs/ncurses:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-apps/texinfo
- test? ( app-misc/screen )"
+ test? ( app-misc/screen )
+"
src_configure() {
- econf \
- $(use_enable experimental)
+ econf $(use_enable experimental)
}
src_test() {
@@ -31,5 +33,6 @@ src_test() {
# when an incompatible screenrc is found
touch tests/screenrc || die
export SYSSCREENRC=tests/screenrc SCREENRC=tests/screenrc
+
default
}