summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-07-25 17:23:10 +0200
committerMichael Weber <xmw@gentoo.org>2016-07-25 17:23:25 +0200
commita04f61b7bbfe1e82cf00e9354fc5d6f3b389f719 (patch)
treec19ea8076175b26bf3bd711d34bdda217533530c /app-text
parentx11-plugins/pidgin-skypeweb-1.2: version bump (diff)
downloadgentoo-a04f61b7bbfe1e82cf00e9354fc5d6f3b389f719.tar.gz
gentoo-a04f61b7bbfe1e82cf00e9354fc5d6f3b389f719.tar.bz2
gentoo-a04f61b7bbfe1e82cf00e9354fc5d6f3b389f719.zip
app-text/paps: Fix bad handling of empty files (bug 566050).
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-text')
-rw-r--r--app-text/paps/files/paps-0.6.8-fix-empty-file.patch23
-rw-r--r--app-text/paps/paps-0.6.8-r2.ebuild38
2 files changed, 61 insertions, 0 deletions
diff --git a/app-text/paps/files/paps-0.6.8-fix-empty-file.patch b/app-text/paps/files/paps-0.6.8-fix-empty-file.patch
new file mode 100644
index 000000000000..ae334d1d28c0
--- /dev/null
+++ b/app-text/paps/files/paps-0.6.8-fix-empty-file.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/show_bug.cgi?id=566050#c2
+
+--- paps-0.6.8/src/paps.c
++++ paps-0.6.8/src/paps.c
+@@ -569,11 +569,14 @@
+
+ fclose (file);
+
+- /* Add a trailing new line if it is missing */
+- if (inbuf->str[inbuf->len-1] != '\n')
+- g_string_append(inbuf, "\n");
++ if (inbuf->len) {
++ /* Add a trailing new line if it is missing */
++ if (inbuf->str[inbuf->len-1] != '\n')
++ g_string_append(inbuf, "\n");
+
+- text = inbuf->str;
++ text = inbuf->str;
++ } else
++ text = g_strdup("\n");
+ g_string_free (inbuf, FALSE);
+
+ return text;
diff --git a/app-text/paps/paps-0.6.8-r2.ebuild b/app-text/paps/paps-0.6.8-r2.ebuild
new file mode 100644
index 000000000000..12152b0e4d52
--- /dev/null
+++ b/app-text/paps/paps-0.6.8-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Unicode-aware text to PostScript converter"
+HOMEPAGE="http://paps.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/pango"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fix-as-needed-build.patch \
+ "${FILESDIR}"/${P}-fix-doxygen-acinclude.patch \
+ "${FILESDIR}"/${P}-fix-freetype-include.patch \
+ "${FILESDIR}"/${P}-fix-empty-file.patch
+
+ mv configure.in configure.ac || die
+
+ eautoreconf
+}
+
+src_install() {
+ dobin src/paps
+ doman src/paps.1
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}