summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-02-17 18:05:51 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-02-17 18:06:33 +0200
commit176928a3dd2255e4304d96cf4c08348d60b0089a (patch)
treecdbfda28a08b49a4098707b4ce92719200c2501a /app-text
parentx11-apps/mesa-progs: Remove upstreamed patch (diff)
downloadgentoo-176928a3dd2255e4304d96cf4c08348d60b0089a.tar.gz
gentoo-176928a3dd2255e4304d96cf4c08348d60b0089a.tar.bz2
gentoo-176928a3dd2255e4304d96cf4c08348d60b0089a.zip
app-text/txt2tags: add 3.8
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/txt2tags/Manifest1
-rw-r--r--app-text/txt2tags/metadata.xml6
-rw-r--r--app-text/txt2tags/txt2tags-3.8.ebuild21
3 files changed, 27 insertions, 1 deletions
diff --git a/app-text/txt2tags/Manifest b/app-text/txt2tags/Manifest
index 9cd951b4e07b..88be7f0bb2bd 100644
--- a/app-text/txt2tags/Manifest
+++ b/app-text/txt2tags/Manifest
@@ -1 +1,2 @@
DIST txt2tags-3.7.tar.gz 248392 BLAKE2B cad49f9815f2e8e466a0fa83715eee27c16cc67fac4c0c55324a3ebc22707857a4bb59176b62fbc1a922c465f60dbc6a057b326789f82a9a9b4babb7b8041486 SHA512 70f6b72b9555b881149e29581a200bf5195d740ca134fffb9faab3a8a04909173f40fe7758659bde44efa9aa50e9816e7164d8164f84b2046de500a49906072b
+DIST txt2tags-3.8.tar.gz 252139 BLAKE2B ed830ccd8b8487ce65bdd7a07dba567bb6ea7814d20c38aa7d8a2a5b15f9aa0eca379b0a8f2ff5a0571c151fcdb0152fff4d8a2ae9b4ae275fef8b94d926d0a2 SHA512 a3679505baa12388327a3cdc177c7c218707549140477189960c1172c1c495e193d7d7cb663a546bfec3e6ae6efd4d8936d94f08661ef7195087403855ebe66f
diff --git a/app-text/txt2tags/metadata.xml b/app-text/txt2tags/metadata.xml
index 9ec2b5c95248..adc2a73b4e28 100644
--- a/app-text/txt2tags/metadata.xml
+++ b/app-text/txt2tags/metadata.xml
@@ -1,10 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>ceamac@gentoo.org</email>
+ <name>Viorel Munteanu</name>
+ </maintainer>
<stabilize-allarches/>
<upstream>
<remote-id type="github">txt2tags/txt2tags</remote-id>
<remote-id type="google-code">txt2tags</remote-id>
+ <remote-id type="pypi">txt2tags</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-text/txt2tags/txt2tags-3.8.ebuild b/app-text/txt2tags/txt2tags-3.8.ebuild
new file mode 100644
index 000000000000..93ec2f1c8133
--- /dev/null
+++ b/app-text/txt2tags/txt2tags-3.8.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Generate marked up documents (HTML, etc.)from a plain text file with markup"
+HOMEPAGE="https://txt2tags.org"
+SRC_URI="https://codeload.github.com/txt2tags/txt2tags/tar.gz/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" run.py || die "Tests failed with ${EPYTHON}"
+}