summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 12:36:18 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:17:20 +0100
commit564d51256094e360032c155d564418878f1bfb12 (patch)
treea74b6b129fe43adf9362a26ac1aa9cf6528e4bbf /app-text/sigil
parentapp-text/pastebinit: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-564d51256094e360032c155d564418878f1bfb12.tar.gz
gentoo-564d51256094e360032c155d564418878f1bfb12.tar.bz2
gentoo-564d51256094e360032c155d564418878f1bfb12.zip
app-text/sigil: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-text/sigil')
-rw-r--r--app-text/sigil/sigil-0.9.16-r1.ebuild (renamed from app-text/sigil/sigil-0.9.16.ebuild)22
-rw-r--r--app-text/sigil/sigil-0.9.18.ebuild22
2 files changed, 22 insertions, 22 deletions
diff --git a/app-text/sigil/sigil-0.9.16.ebuild b/app-text/sigil/sigil-0.9.16-r1.ebuild
index a712ce00178e..a9492f58a94c 100644
--- a/app-text/sigil/sigil-0.9.16.ebuild
+++ b/app-text/sigil/sigil-0.9.16-r1.ebuild
@@ -24,9 +24,10 @@ RDEPEND="
dev-libs/boost:=[threads]
dev-libs/libpcre:3=[pcre16]
dev-libs/xerces-c[icu]
- dev-python/css-parser[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/css-parser[${PYTHON_MULTI_USEDEP}]
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]')
>=dev-qt/qtconcurrent-5.12:5
>=dev-qt/qtcore-5.12:5
>=dev-qt/qtgui-5.12:5
@@ -35,14 +36,13 @@ RDEPEND="
>=dev-qt/qtwidgets-5.12:5
>=dev-qt/qtxmlpatterns-5.12:5
sys-libs/zlib[minizip]
- plugins? (
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/cssselect[${PYTHON_USEDEP}]
- dev-python/cssutils[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/regex[${PYTHON_USEDEP}]
- )
+ plugins? ( $(python_gen_cond_dep \
+ 'dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/cssselect[${PYTHON_MULTI_USEDEP}]
+ dev-python/cssutils[${PYTHON_MULTI_USEDEP}]
+ dev-python/html5lib[${PYTHON_MULTI_USEDEP}]
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ dev-python/regex[${PYTHON_MULTI_USEDEP}]') )
system-mathjax? ( dev-libs/mathjax )
"
DEPEND="${RDEPEND}"
diff --git a/app-text/sigil/sigil-0.9.18.ebuild b/app-text/sigil/sigil-0.9.18.ebuild
index ee2155ae5c35..697fccf8b9f1 100644
--- a/app-text/sigil/sigil-0.9.18.ebuild
+++ b/app-text/sigil/sigil-0.9.18.ebuild
@@ -24,9 +24,10 @@ RDEPEND="
dev-libs/boost:=[threads]
dev-libs/libpcre:3=[pcre16]
dev-libs/xerces-c[icu]
- dev-python/css-parser[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/css-parser[${PYTHON_MULTI_USEDEP}]
+ dev-python/lxml[${PYTHON_MULTI_USEDEP}]
+ dev-python/six[${PYTHON_MULTI_USEDEP}]')
>=dev-qt/qtconcurrent-5.12:5
>=dev-qt/qtcore-5.12:5
>=dev-qt/qtgui-5.12:5
@@ -34,14 +35,13 @@ RDEPEND="
>=dev-qt/qtwebengine-5.12:5[widgets]
>=dev-qt/qtwidgets-5.12:5
sys-libs/zlib[minizip]
- plugins? (
- dev-python/chardet[${PYTHON_USEDEP}]
- dev-python/cssselect[${PYTHON_USEDEP}]
- dev-python/cssutils[${PYTHON_USEDEP}]
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/regex[${PYTHON_USEDEP}]
- )
+ plugins? ( $(python_gen_cond_dep \
+ 'dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/cssselect[${PYTHON_MULTI_USEDEP}]
+ dev-python/cssutils[${PYTHON_MULTI_USEDEP}]
+ dev-python/html5lib[${PYTHON_MULTI_USEDEP}]
+ dev-python/pillow[${PYTHON_MULTI_USEDEP}]
+ dev-python/regex[${PYTHON_MULTI_USEDEP}]') )
system-mathjax? ( dev-libs/mathjax )
"
DEPEND="${RDEPEND}"