summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-11-15 11:19:48 +0100
committerSam James <sam@gentoo.org>2022-11-22 06:50:22 +0000
commitfa96653f30ccc9561c232e9fe8ca7d5faad74dea (patch)
treeaed68a80514d4d59381ff4d2448c758b29989bbb /app-text/recode
parentapp-text/recode: revbump, fix build for clang16 (diff)
downloadgentoo-fa96653f30ccc9561c232e9fe8ca7d5faad74dea.tar.gz
gentoo-fa96653f30ccc9561c232e9fe8ca7d5faad74dea.tar.bz2
gentoo-fa96653f30ccc9561c232e9fe8ca7d5faad74dea.zip
app-text/recode: drop 3.7.9, 3.7.11
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/28216 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/recode')
-rw-r--r--app-text/recode/Manifest2
-rw-r--r--app-text/recode/recode-3.7.11.ebuild59
-rw-r--r--app-text/recode/recode-3.7.9.ebuild58
3 files changed, 0 insertions, 119 deletions
diff --git a/app-text/recode/Manifest b/app-text/recode/Manifest
index 32ed582d7242..0f94ebaf0544 100644
--- a/app-text/recode/Manifest
+++ b/app-text/recode/Manifest
@@ -1,3 +1 @@
-DIST recode-3.7.11.tar.gz 2405035 BLAKE2B 363499d265c201e9c8c4be0821efd9900e72aa21aee2e6f77ea85b5a31afb43a905eb5a88cbf1be0fd40bdc44f8707b24fe5a896cd645f5674ae69027bd167a9 SHA512 b00be87c321f5fef6aa0a7813f97b2368cbcac28f0c9e856b81e84ff878689428e1ca079a255ad44beecdcdf6efc7406517fa3116f12886bcc421b323e3810ce
DIST recode-3.7.12.tar.gz 2399126 BLAKE2B 420ba6f96d532da4ae0e1861b512c39ad59f1f63b0e0ef061dcff95c15ff4ed82a3b7bb72f6abb29f85588476a76cb5d50151ca9e3f857c2c1c09727ccdd2890 SHA512 365602bf7b20e5362d13d1ab5269419f7f0838fb81dc01c466ea99c38eb1b979f8d707d24ca3dabbd3a0c65cde97704b570007ac60689d88bbafd33351d37d95
-DIST recode-3.7.9.tar.gz 2230259 BLAKE2B 36039ba9e62c5113231764dfa9cffa73b7ff5cd91bab622a0daf0a48a73ab8a62afd16132cec2590eed14623ce5b86ad057e8ca8454cf8185869f0780b3523e7 SHA512 277074dee63cdc7f1a1be2acca67481b8fb816bd4319fe8e882696e42d15309750b930fa9e8d6286e714132a976f0eaf87f718560d6cb86eeaa79b86f0700a6c
diff --git a/app-text/recode/recode-3.7.11.ebuild b/app-text/recode/recode-3.7.11.ebuild
deleted file mode 100644
index 8a466fea9cdf..000000000000
--- a/app-text/recode/recode-3.7.11.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit flag-o-matic python-any-r1 toolchain-funcs
-
-DESCRIPTION="Convert files between various character sets"
-HOMEPAGE="https://github.com/rrthomas/recode"
-SRC_URI="https://github.com/rrthomas/recode/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3+"
-# librecode soname version
-SLOT="0/3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
-IUSE="nls test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="virtual/libiconv"
-DEPEND="
- ${RDEPEND}
- sys-devel/flex
-"
-BDEPEND="
- nls? ( sys-devel/gettext )
- test? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ')
- )
-"
-
-python_check_deps() {
- if use test ; then
- python_has_version "dev-python/cython[${PYTHON_USEDEP}]" || return 1
- fi
-}
-
-src_configure() {
- tc-export CC LD
-
- # on solaris -lintl is needed to compile
- [[ ${CHOST} == *-solaris* ]] && append-libs "-lintl"
-
- # --without-included-gettext means we always use system headers
- # and library
- econf \
- $(use_enable nls) \
- --disable-static
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/app-text/recode/recode-3.7.9.ebuild b/app-text/recode/recode-3.7.9.ebuild
deleted file mode 100644
index a3592d9cc9d5..000000000000
--- a/app-text/recode/recode-3.7.9.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit flag-o-matic python-any-r1 toolchain-funcs
-
-DESCRIPTION="Convert files between various character sets"
-HOMEPAGE="https://github.com/rrthomas/recode"
-SRC_URI="https://github.com/rrthomas/recode/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3+"
-# librecode soname version
-SLOT="0/3"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
-IUSE="nls test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="virtual/libiconv"
-DEPEND="
- ${RDEPEND}
- sys-devel/flex
-"
-BDEPEND="
- nls? ( sys-devel/gettext )
- test? (
- ${PYTHON_DEPS}
- $(python_gen_any_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ')
- )
-"
-
-python_check_deps() {
- if use test ; then
- python_has_version "dev-python/cython[${PYTHON_USEDEP}]" || return 1
- fi
-}
-
-src_configure() {
- tc-export CC LD
-
- # on solaris -lintl is needed to compile
- [[ ${CHOST} == *-solaris* ]] && append-libs "-lintl"
-
- # --without-included-gettext means we always use system headers
- # and library
- econf \
- $(use_enable nls) \
- --disable-static
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-}