summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-08 02:48:33 +0100
committerSam James <sam@gentoo.org>2023-10-08 02:49:50 +0100
commit98f3a1c046fcd03254f4c082b9c070a109d9781e (patch)
tree3d64c9e3434ed35e1af99ebd2be5ca3bb3ac3917 /app-text/qpdf
parentnet-dns/c-ares: fix LICENSE (diff)
downloadgentoo-98f3a1c046fcd03254f4c082b9c070a109d9781e.tar.gz
gentoo-98f3a1c046fcd03254f4c082b9c070a109d9781e.tar.bz2
gentoo-98f3a1c046fcd03254f4c082b9c070a109d9781e.zip
app-text/qpdf: add 11.6.2
Closes: https://bugs.gentoo.org/914099 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/qpdf')
-rw-r--r--app-text/qpdf/Manifest2
-rw-r--r--app-text/qpdf/qpdf-11.6.2.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/app-text/qpdf/Manifest b/app-text/qpdf/Manifest
index 6a696591ebe2..da46c139147c 100644
--- a/app-text/qpdf/Manifest
+++ b/app-text/qpdf/Manifest
@@ -10,3 +10,5 @@ DIST qpdf-11.5.0-doc.zip 6858454 BLAKE2B bd1e7f974eb2b0e22395216a1e3d55b18b1140c
DIST qpdf-11.5.0.tar.gz 18638138 BLAKE2B 54545665a31cf0cbfc50faa18f1dc64f036cd5bfd2b274ff443718e704e26f3a8cf83600f9dd7d8039cf4bdcaf42e1c14f03db775226b56c8ba53be33e0ca522 SHA512 3c8504de11c34e7d623b829c0c987ba5555c2bdcfdd5d4408d29f321fd79154ec2d6fa76f45556046dfc931b51bd75e3062973c36c8020383acacbe56c90e04c
DIST qpdf-11.6.1-doc.zip 6861634 BLAKE2B bc9f566de9bc403e9a81184ef860cf2c39253228e4ad776f999d8b896958242fca4833517b03ce1c92e03983a39a17a1b02f3605df354afc414b82a5dbf6398b SHA512 efb8ff85c2a5c712f2f78213eddd6c8568727ff6d15d31da2880ee487053c9d703c47ac383f008f6abbf87feb262c6aa2a84419d21e7b4859215509e80d6814a
DIST qpdf-11.6.1.tar.gz 18646767 BLAKE2B fd6163963eb192b38ed1e78cba443e9e247e6ff408efd6cb480c81ac3d9d233e00edf9ef0858e51ac755b2b7cea0d8763ac6dda3fe9d54618114b4b3a00d5b15 SHA512 a3ce1a531331a6f7e33244d598118f9463f92f0466fd1f2aa3dcdc6dc2c1db0811d00e5ff16ad33ccc81a702ff8dbec719f56194f944de1e00f5e6cc8ed17a69
+DIST qpdf-11.6.2-doc.zip 6863319 BLAKE2B d140a35de156a40dc62ac900f2095d826760d05bdb58c2b6d8ba8ec68d823d9ab5022027d634f82b3a182ec3a842f22f44b659df7355c55e74d8e31a11458a2b SHA512 0d81c3a467833fd66668e2cbc6afef3346cbf2eeb01eaffc532165a19910a000e9e7eea0174e4b930ecd55e423680e39a7b0c8bb6f618e6f9c019058b6bd90ce
+DIST qpdf-11.6.2.tar.gz 18656098 BLAKE2B e34c40dcea3e6a3a25a3624bff6afea80ee18f4f02c16b2442a8fc622ab0b6eddd1e8660f3c35f4e3115206a34a97c64e53b9aac46e896517ed5c05aed9d341b SHA512 58f8eff51f4bf64a5cbc40af467aa0626f7f25a31222711e06596f9fccd9ecc0d9d7d87cf65e2055d23409d23458e33bc94f303cd797d00af3c6bc5872b3ef28
diff --git a/app-text/qpdf/qpdf-11.6.2.ebuild b/app-text/qpdf/qpdf-11.6.2.ebuild
new file mode 100644
index 000000000000..cd7413346d61
--- /dev/null
+++ b/app-text/qpdf/qpdf-11.6.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake bash-completion-r1
+
+DESCRIPTION="Command-line tool for structural, content-preserving transformation of PDF files"
+HOMEPAGE="https://qpdf.sourceforge.net/"
+# TODO: verify-sig
+SRC_URI="https://github.com/qpdf/qpdf/releases/download/v${PV}/${P}.tar.gz"
+SRC_URI+=" doc? ( https://github.com/qpdf/qpdf/releases/download/v${PV}/${P}-doc.zip )"
+
+LICENSE="|| ( Apache-2.0 Artistic-2 )"
+# Subslot for libqpdf soname version (just represent via major version)
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples gnutls ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ media-libs/libjpeg-turbo:=
+ sys-libs/zlib
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? ( dev-libs/openssl:= )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ app-text/ghostscript-gpl[tiff(+)]
+ media-libs/tiff
+ sys-apps/diffutils
+ )
+"
+BDEPEND="
+ dev-lang/perl
+ doc? ( app-arch/unzip )
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # glibc only (bug #899052)
+ malloc_info
+)
+
+src_configure() {
+ # Keep an eye on https://qpdf.readthedocs.io/en/stable/packaging.html.
+ local mycmakeargs=(
+ -DINSTALL_EXAMPLES=$(usex examples)
+
+ # Avoid automagic crypto deps
+ -DUSE_IMPLICIT_CRYPTO=OFF
+ -DALLOW_CRYPTO_NATIVE=ON
+
+ # Breaks install with USE=-doc in 11.0.0?
+ #-DINSTALL_MANUAL=ON
+ )
+
+ if use ssl ; then
+ local crypto_provider=$(usex gnutls GNUTLS OPENSSL)
+ local crypto_provider_lowercase=${crypto_provider,,}
+ mycmakeargs+=(
+ -DDEFAULT_CRYPTO=${crypto_provider_lowercase}
+ -DREQUIRE_CRYPTO_${crypto_provider}=ON
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ if use doc ; then
+ mv "${WORKDIR}"/${P}-doc "${BUILD_DIR}"/manual/doc-dist || die
+ fi
+
+ cmake_src_install
+
+ # Completions
+ dobashcomp completions/bash/qpdf
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_qpdf
+}