summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-22 01:59:13 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-22 02:17:57 -0600
commit130653df48b799615eddd99ad5972a368b0f03e7 (patch)
tree70a30a01f2956aa753b656f32b3642680ee1e756 /app-text/llpp
parentsys-apps/grep: Version bump (v3.3) (diff)
downloadgentoo-130653df48b799615eddd99ad5972a368b0f03e7.tar.gz
gentoo-130653df48b799615eddd99ad5972a368b0f03e7.tar.bz2
gentoo-130653df48b799615eddd99ad5972a368b0f03e7.zip
app-text/llpp: respect user compiler and add libdir setting
To avoid showing wrong arch linking warnings on multi-arch systems. Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-text/llpp')
-rw-r--r--app-text/llpp/files/Makefile5
-rw-r--r--app-text/llpp/llpp-30.ebuild2
2 files changed, 4 insertions, 3 deletions
diff --git a/app-text/llpp/files/Makefile b/app-text/llpp/files/Makefile
index 1fb99c9a2118..0bd94cab00f2 100644
--- a/app-text/llpp/files/Makefile
+++ b/app-text/llpp/files/Makefile
@@ -5,12 +5,13 @@ endif
# paths
PREFIX ?= /usr/local
+LIBDIR ?= /usr/lib
# includes and libs
PKGCONF_DEPS := freetype2 harfbuzz libopenjp2 libjpeg mupdf x11 zlib
CPPFLAGS += -D_GNU_SOURCE -DFFP
-CFLAGS += -g -std=c99 -pedantic -Wall -Wextra -Wshadow $(shell pkg-config --cflags $(PKGCONF_DEPS))
-LDLIBS = -lpthread -ljbig2dec $(shell pkg-config --libs $(PKGCONF_DEPS))
+CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wshadow $(shell pkg-config --cflags $(PKGCONF_DEPS))
+LDLIBS = -L$(LIBDIR) -lpthread -ljbig2dec $(shell pkg-config --libs $(PKGCONF_DEPS))
# ocaml
CAMLOPT = ocamlopt
diff --git a/app-text/llpp/llpp-30.ebuild b/app-text/llpp/llpp-30.ebuild
index 9f5ec30d5069..3ba1ce6fe451 100644
--- a/app-text/llpp/llpp-30.ebuild
+++ b/app-text/llpp/llpp-30.ebuild
@@ -51,7 +51,7 @@ src_prepare() {
}
src_compile() {
- emake -j1 VERSION=${PV}
+ emake -j1 VERSION=${PV} CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
}
src_install() {