summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-16 04:12:26 +0000
committerSam James <sam@gentoo.org>2023-02-16 04:12:26 +0000
commit6e9dc1610d5275a51458ddb824609d8fd833f051 (patch)
treee8db851bade6a1cf85c8dbecaca635e99f8529b9 /app-shells
parentapp-admin/apachetop: add 0.23.2 (diff)
downloadgentoo-6e9dc1610d5275a51458ddb824609d8fd833f051.tar.gz
gentoo-6e9dc1610d5275a51458ddb824609d8fd833f051.tar.bz2
gentoo-6e9dc1610d5275a51458ddb824609d8fd833f051.zip
app-shells/fzf: add 0.38.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.38.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index 7200acf50e44..18ab48741efc 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -2,3 +2,5 @@ DIST fzf-0.36.0-deps.tar.xz 16806808 BLAKE2B f121b3000bc5a0d72ee5cb66f59f4f44c41
DIST fzf-0.36.0.tar.gz 229126 BLAKE2B faa04870b7654b1ffb2f1c453636e33eab94e682c7db4702719419a5eca5ea136c657179248dd646573a625f575c823f9dcfd0023a96390bbf689e7455224411 SHA512 8e87dbd3b5ae9e0dc6a76855f7c75c9b4edc8ce797b2cd4eda053c4e1d618bb9afb2b24602e01776a49e47a00f2cd803ed433043f0acec8d385f741b13583e9e
DIST fzf-0.37.0-deps.tar.xz 16806808 BLAKE2B f121b3000bc5a0d72ee5cb66f59f4f44c41af30f28ca935a607b424399d12dc762f25811aea999e5de126e2727f8bda614e026da6983ed535d048a7229a07065 SHA512 121c6b1be0cd3af752b11461a72c22e3bc55eec12c12367b354a4ff4d4dc75fb0215cf19cec52008473045c6330a4af71b2e3a14a9a0a124e18aacc1aaad97a9
DIST fzf-0.37.0.tar.gz 230469 BLAKE2B 3281ae0e9b13f8be9d2bc5eb5bfab534a7b56279346ed500932840fb90e3bf0137c5610fdc5928faa99fadbb2cb10b98c46eea7a41f3a76cff3805ed52d255a7 SHA512 bb8cb4b6c83e978c45de757784f29be883070ef7abab2fe2dd89bc668be7628a3f476f97abf82f98220942c37317df0404e3fd2205c2e93ec506a6ca8beaf74c
+DIST fzf-0.38.0-deps.tar.xz 16806808 BLAKE2B f121b3000bc5a0d72ee5cb66f59f4f44c41af30f28ca935a607b424399d12dc762f25811aea999e5de126e2727f8bda614e026da6983ed535d048a7229a07065 SHA512 121c6b1be0cd3af752b11461a72c22e3bc55eec12c12367b354a4ff4d4dc75fb0215cf19cec52008473045c6330a4af71b2e3a14a9a0a124e18aacc1aaad97a9
+DIST fzf-0.38.0.tar.gz 232613 BLAKE2B fa05732fadfa47646d67aaf7bca94d143c5cb9267520e83a2278aac88c32624cb2dc87d198e1e83348fc3bb1339d38cb1b59e0fa251aa97c5f32daf9c0f71603 SHA512 a9a89f8e228b52fc20b21624c9024c932dee2a786a711788b1ea8b0c2829099be0b74e6a5e2676ec23288a846af9feda683ac4644409848fb362e4ff9278f5fc
diff --git a/app-shells/fzf/fzf-0.38.0.ebuild b/app-shells/fzf/fzf-0.38.0.ebuild
new file mode 100644
index 000000000000..d4e4aabb02a8
--- /dev/null
+++ b/app-shells/fzf/fzf-0.38.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=352ea072269dfe2a3c429785a95a2f22887ccda3
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug 795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}