summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-09-02 14:20:54 -0400
committerMatt Turner <mattst88@gentoo.org>2024-09-02 14:21:56 -0400
commit57a8a60c073ceedc0708c8d48d4373d81e297e2f (patch)
tree341365d60b973c2f628a54cd6226e149c307ee6d /app-shells
parentsys-auth/elogind: Drop musl patches (diff)
downloadgentoo-57a8a60c073ceedc0708c8d48d4373d81e297e2f.tar.gz
gentoo-57a8a60c073ceedc0708c8d48d4373d81e297e2f.tar.bz2
gentoo-57a8a60c073ceedc0708c8d48d4373d81e297e2f.zip
app-shells/fzf: Version bump to 0.55.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.55.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index ed9063e08744..79d867044729 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -2,3 +2,5 @@ DIST fzf-0.53.0-deps.tar.xz 5882848 BLAKE2B b7faec7c2afd60642c27afa6f3c7a99fc140
DIST fzf-0.53.0.tar.gz 286797 BLAKE2B f6355c168f2b587cc2d0b21ef483812db7e077e4bf19517a4fc8fed43dd6b3f557ce1a28630075b4f1e6238aacf02ce10ceb1afd4d7fe5ca6e2453c132c56d80 SHA512 4122b49e8fec936ec4da79cdb7a7ed1891caadf842008ae36aac5ce0aa1c2263bed68fa0332f2cb4f2b38551469af0f14874410407b922827e62767032e92393
DIST fzf-0.54.3-deps.tar.xz 5875812 BLAKE2B 19e27c17c86ae5df2a84bfde2a7df912a3e1b4e46c1475da0d10b190df272de0f09b3e546c84bc78e012788bd0842125681e43fe090f244bbd538bf2c6050175 SHA512 29a006cdb8352090aeda6d15e020700d123a1fa1e125bb82058253054e0cefc2d52b055392b38ba9b262bf0802609a7d99b49f602081fb472f0d0c7d709fcc59
DIST fzf-0.54.3.tar.gz 292944 BLAKE2B 4a2e7a6cc50504215fa14ef6559df8b14fa0d89a499ca06f25b170cd2456d22cc30260de80821db9525ba4d6ece24ab39d863f23004f680bd3cf1d2a6985ec25 SHA512 e93056c3030e4a9dca59066fe111ef7539040a2e5bb800030d8f3e032acfae7db5fd2cf32aa7a45b505ec180e95c05bebe801bfc60c65db15fe9b647959ea987
+DIST fzf-0.55.0-deps.tar.xz 5891700 BLAKE2B 63de6f3817796eef8c6e69c7bdf66e2f379be1e438558245cedb4dfa6ab16ad6dc74fb901481359bd099533b48f4f4670a83588d7befe4812085b7c6bb2faf58 SHA512 2c3f0affe988e8dabb743425b707ec082f59d185abad7f9d82043d922890060151b06c89056c201df7a328d67edcd54ed91ca1c62d1dd4648ee72977186ffeb4
+DIST fzf-0.55.0.tar.gz 295984 BLAKE2B 304eb1c3ce682827d99ed699f2432eccb9cfe2025e331a291a43068000e9423913642a41cf124dbedf494adafd85a2ddcd5311f16f1a41b98550a0befd209f03 SHA512 b931b24b9398d189e83caf69fc7bdabbd906be6caed9d84dfe8ce0ec4ac980a78a89b7af988105996c6f217604d00f73efbf7be89b2c871e8b1f57b5e6bb72bb
diff --git a/app-shells/fzf/fzf-0.55.0.ebuild b/app-shells/fzf/fzf-0.55.0.ebuild
new file mode 100644
index 000000000000..380854366f61
--- /dev/null
+++ b/app-shells/fzf/fzf-0.55.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=9e92b6f11e0f59272de410f56493893334071e6e
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~mattst88/distfiles/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug #795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}