summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-23 11:24:38 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-23 12:00:07 +0200
commit0f4bf7b655c6cad37d58848328939790aaa75196 (patch)
tree0c3a79a414133621ad378ee7dc83a103fdc7d92d /app-shells
parentnet-libs/zeromq: update metadata (diff)
downloadgentoo-0f4bf7b655c6cad37d58848328939790aaa75196.tar.gz
gentoo-0f4bf7b655c6cad37d58848328939790aaa75196.tar.bz2
gentoo-0f4bf7b655c6cad37d58848328939790aaa75196.zip
app-shells/pwsh: remove libSystem.IO.Ports.Native.so on musl
Closes: https://bugs.gentoo.org/922529 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh/pwsh-7.4.1-r1.ebuild (renamed from app-shells/pwsh/pwsh-7.4.1.ebuild)8
-rw-r--r--app-shells/pwsh/pwsh-7.4.5-r1.ebuild (renamed from app-shells/pwsh/pwsh-7.4.5.ebuild)8
2 files changed, 14 insertions, 2 deletions
diff --git a/app-shells/pwsh/pwsh-7.4.1.ebuild b/app-shells/pwsh/pwsh-7.4.1-r1.ebuild
index e2b5e1e380a4..6953d1d14729 100644
--- a/app-shells/pwsh/pwsh-7.4.1.ebuild
+++ b/app-shells/pwsh/pwsh-7.4.1-r1.ebuild
@@ -385,10 +385,16 @@ src_install() {
insinto "${dest_root}/ref"
doins "${WORKDIR}/${P}_ref"/*
- # Remove "libpsl-native.so" provided by "microsoft.powershell.native".
+ # Replace "libpsl-native.so" provided by "microsoft.powershell.native".
rm "${ED}/${dest_root}/libpsl-native.so" || die
dosym -r "/usr/$(get_libdir)/libpsl-native.so" "${dest_root}/libpsl-native.so"
+ # On musl remove "libSystem.IO.Ports.Native.so" linked against glibc.
+ if ! use elibc_glibc ; then
+ ewarn "libSystem.IO.Ports.Native.so is available only for glibc, removing it"
+ rm "${ED}/${dest_root}/libSystem.IO.Ports.Native.so" || die
+ fi
+
if use gui ; then
newicon assets/ps_black_128.svg "powershell-${SLOT}.svg"
make_desktop_entry "pwsh-${SLOT} -l" "PowerShell ${SLOT}" \
diff --git a/app-shells/pwsh/pwsh-7.4.5.ebuild b/app-shells/pwsh/pwsh-7.4.5-r1.ebuild
index 8417ef5ac9f1..8cf2a585c24f 100644
--- a/app-shells/pwsh/pwsh-7.4.5.ebuild
+++ b/app-shells/pwsh/pwsh-7.4.5-r1.ebuild
@@ -391,10 +391,16 @@ src_install() {
insinto "${dest_root}/ref"
doins "${WORKDIR}/${P}_ref"/*
- # Remove "libpsl-native.so" provided by "microsoft.powershell.native".
+ # Replace "libpsl-native.so" provided by "microsoft.powershell.native".
rm "${ED}/${dest_root}/libpsl-native.so" || die
dosym -r "/usr/$(get_libdir)/libpsl-native.so" "${dest_root}/libpsl-native.so"
+ # On musl remove "libSystem.IO.Ports.Native.so" linked against glibc.
+ if ! use elibc_glibc ; then
+ ewarn "libSystem.IO.Ports.Native.so is available only for glibc, removing it"
+ rm "${ED}/${dest_root}/libSystem.IO.Ports.Native.so" || die
+ fi
+
if use gui ; then
newicon assets/ps_black_128.svg "powershell-${SLOT}.svg"
make_desktop_entry "pwsh-${SLOT} -l" "PowerShell ${SLOT}" \