summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-12 14:03:23 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-12 14:05:57 -0500
commitb49d0aa028865363c0be616d63c63c2682ee3005 (patch)
tree3bee58d310eafa819e3a9753c531c21433b8f1dd /app-portage
parentdev-debug: New category (diff)
downloadgentoo-b49d0aa028865363c0be616d63c63c2682ee3005.tar.gz
gentoo-b49d0aa028865363c0be616d63c63c2682ee3005.tar.bz2
gentoo-b49d0aa028865363c0be616d63c63c2682ee3005.zip
app-portage/iwdevtools: add 0.12.10
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.12.10.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index f15b8a609171..c6b3ca00800e 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
+DIST iwdevtools-0.12.10.tar.gz 91518 BLAKE2B 7a017c6666c67903d5a67b77508d8e86578d673b58cc9763fb6a435697e6dca1da15d9aa40a53e1f84c2966976fd3deafe9351992f886ddf130fe4f75637d105 SHA512 d321259334931be9e488bac8f322d0f042c513a4c84a5b656c381ebb51d8fa1fc7bdf3214b64ad9ea9204f3a5f4dee485325190f8d9a29e918a8cc209d108e8f
DIST iwdevtools-0.12.9.tar.gz 91444 BLAKE2B 81d4011705ca40bc751a2a534b3f07845da26d30de8bacf8bbe0a283701a7a61d166f021da7089cbc7ec64bd1b76308d1a43edebb794a6ff7cbd85e10990a8dd SHA512 1cc4a5efcf1dddd787ae26cda732d986c714a68ffd12715c4aa4ae5e9da809c2a451c8193d0f4b525496f5226344bc757566957cee4af364201a43c4ae39b716
diff --git a/app-portage/iwdevtools/iwdevtools-0.12.10.ebuild b/app-portage/iwdevtools/iwdevtools-0.12.10.ebuild
new file mode 100644
index 000000000000..7f36be50e156
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.12.10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools/"
+SRC_URI="
+ https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1:0[readline]
+ dev-libs/libxml2:2
+ sys-apps/coreutils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )
+"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}