summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-01 05:11:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-01 05:13:15 +0100
commit9ff164104bdfe237037cb06dcc8806a3218b11c3 (patch)
treec0f6a719a42df69526adacc6a912d7103867374b /app-portage
parentapp-portage/kuroneko: Remove old (diff)
downloadgentoo-9ff164104bdfe237037cb06dcc8806a3218b11c3.tar.gz
gentoo-9ff164104bdfe237037cb06dcc8806a3218b11c3.tar.bz2
gentoo-9ff164104bdfe237037cb06dcc8806a3218b11c3.zip
app-portage/kuroneko: Bump to 0.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/kuroneko/Manifest1
-rw-r--r--app-portage/kuroneko/kuroneko-0.1.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-portage/kuroneko/Manifest b/app-portage/kuroneko/Manifest
index 2255f6141a9a..bd134aea8a62 100644
--- a/app-portage/kuroneko/Manifest
+++ b/app-portage/kuroneko/Manifest
@@ -1 +1,2 @@
DIST kuroneko-0.1.3.tar.gz 10872 BLAKE2B 3dc85e92a4490501897e25949d258341e661672a2bd1fbce2673d3be6ead3599269cfc93884ad05da9ee41f90b60d17faeebb6b806da870458c8cf13e33fe58e SHA512 b388e0c19faae282b158e63a2ef3f54af98932e5f0efe96dcdcbd0ace509a22a1f7887834c94813912a03734448bc230767ab8e1367545f5cc877d778954fa0c
+DIST kuroneko-0.1.4.tar.gz 11369 BLAKE2B 607d5b59720ba718dfb24d5f253a38d35c825ff9f29284bb2b50ed7a5c09ac044b514953af67217d2f840d97f1530e4608ba244cae5ca71316176bb873d28d8b SHA512 d71a0298080cfd453788fb8c9ab936b3aa7e6b67337ac8ee52d4c859b4539a9a319c81811da5f955a0c7bdf5a43a04a8b5911dc02d09d3bc212a441b217957a4
diff --git a/app-portage/kuroneko/kuroneko-0.1.4.ebuild b/app-portage/kuroneko/kuroneko-0.1.4.ebuild
new file mode 100644
index 000000000000..f48a1fb55c96
--- /dev/null
+++ b/app-portage/kuroneko/kuroneko-0.1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Vulnerability checker using data scraped from Gentoo Bugzilla"
+HOMEPAGE="https://github.com/projg2/kuroneko/"
+SRC_URI="
+ https://github.com/projg2/kuroneko/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="scraper"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ sys-apps/pkgcore[${PYTHON_USEDEP}]
+ scraper? (
+ dev-python/bracex[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/bracex[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest