summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-31 08:02:26 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-31 08:14:53 -0400
commit80bc9e69eb2271add5836724c876b89bc6cebfec (patch)
tree6b54442bbf7b9fbd1ba1908b41a1b9b69a0dc2c9 /app-portage
parentx11-terms/kitty: add 0.35.1 (diff)
downloadgentoo-80bc9e69eb2271add5836724c876b89bc6cebfec.tar.gz
gentoo-80bc9e69eb2271add5836724c876b89bc6cebfec.tar.bz2
gentoo-80bc9e69eb2271add5836724c876b89bc6cebfec.zip
app-portage/iwdevtools: add 0.12.12
Unkeyworded for now given waiting to confirm whether the llvm-r1 change was abandoned or merely forgotten given the change mentioned in the NEWS.rst has still not been comitted (just noticed). Not a big deal either way, but may spare some devs from updating ebuilds for nothing if it was abandoned. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.12.12.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 0f22d1cf5191..816c0d4935c8 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.12.11.tar.gz 91626 BLAKE2B ffdc58c9a76105031b3be771d49d3b1afa7550333bc8cc2eae6a8ba798974e363aecf6c3f7f3f76e6d0cf6e3aac1ccd6f73bfafe3f0ae99987099fb3896ecb0f SHA512 6083a7ddef331b8f7ef96491c438096b7c920dedbe2ba3f0d74e6542592cfabbe442939609f10cddce736c21d02794900e8428c10b2b2b46ed988f6efe80351b
+DIST iwdevtools-0.12.12.tar.gz 91784 BLAKE2B 7df4f1996ad55090b65ea87c67a5ae15c5f661a5fd1e21cddbb157e651c4b52aa8e8223f4071dabc726605958942847e17678fc4e102037c6937963ef69fd7bc SHA512 13142c9df7892a55a9fc2172fb0a9480b1d91cfa23dca71a22b1c7f5882bfd84af9c17228a0e8251f1fac0840196c1e18b34f3568b30d04a20b1a8188fa31150
diff --git a/app-portage/iwdevtools/iwdevtools-0.12.12.ebuild b/app-portage/iwdevtools/iwdevtools-0.12.12.ebuild
new file mode 100644
index 000000000000..dea56371a460
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.12.12.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools/"
+SRC_URI="
+ https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+#KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1:0[readline]
+ dev-libs/libxml2:2
+ sys-apps/coreutils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )
+"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}