summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-04-14 20:57:33 +0200
committerSebastian Pipping <sping@gentoo.org>2024-04-14 20:58:40 +0200
commit7739eb8c874e260ab0064e6ed3f247da973c4460 (patch)
tree99b0bfdedd4ac1d6bc88d09436f2bd1e54a6d679 /app-portage
parentapp-text/wiki2beamer: PEP 517 + Python 3.12 (diff)
downloadgentoo-7739eb8c874e260ab0064e6ed3f247da973c4460.tar.gz
gentoo-7739eb8c874e260ab0064e6ed3f247da973c4460.tar.bz2
gentoo-7739eb8c874e260ab0064e6ed3f247da973c4460.zip
app-portage/overlint: Python 3.12
Closes: https://bugs.gentoo.org/929355 Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/overlint/overlint-0.5.3-r5.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-portage/overlint/overlint-0.5.3-r5.ebuild b/app-portage/overlint/overlint-0.5.3-r5.ebuild
new file mode 100644
index 000000000000..17fd77bb2283
--- /dev/null
+++ b/app-portage/overlint/overlint-0.5.3-r5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Simple tool for static analysis of overlays"
+HOMEPAGE="https://cgit.gentoo.org/proj/overlint.git"
+SRC_URI="https://www.hartwork.org/public/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sys-apps/portage[${PYTHON_USEDEP}]"