summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-31 17:30:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-31 17:32:52 +0100
commit40dc9f30dc7b0f7082ac1cd9a89b96c3b0e24ba3 (patch)
tree8c43f59c529588f87be6f2f35206147b5c1d03f2 /app-portage
parentdev-vcs/subversion: drop 1.14.2-r1 (diff)
downloadgentoo-40dc9f30dc7b0f7082ac1cd9a89b96c3b0e24ba3.tar.gz
gentoo-40dc9f30dc7b0f7082ac1cd9a89b96c3b0e24ba3.tar.bz2
gentoo-40dc9f30dc7b0f7082ac1cd9a89b96c3b0e24ba3.zip
app-portage/pycargoebuild: Bump to 0.13.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pycargoebuild/Manifest1
-rw-r--r--app-portage/pycargoebuild/pycargoebuild-0.13.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-portage/pycargoebuild/Manifest b/app-portage/pycargoebuild/Manifest
index 84114dc0babe..ad51e2cdbaa0 100644
--- a/app-portage/pycargoebuild/Manifest
+++ b/app-portage/pycargoebuild/Manifest
@@ -1 +1,2 @@
DIST pycargoebuild-0.13.3.gh.tar.gz 48888 BLAKE2B 9cba07fec9c3477fcf27b8ea13a4025c312120fa49b5e85537f88fe3243ad8882b96406be2c4e3d9c5bfb0ec1fd900f8d5f07618a391ad1de67f0bb1fccf994f SHA512 6c7e606f5afcb2a0280dbc0d49bf142295c2e237586fabbf420b589cbe9273a772864dd65bfb6c1643f4b324183505cc089f6c83f311d96a646a85b171544f61
+DIST pycargoebuild-0.13.4.gh.tar.gz 51482 BLAKE2B 158f48e9c37ed3791749eb6b8c906a8ca9a9af84a3f2e4fa909e8076def15b14eeaa0805cf8a4dccf71ed70a9dff05b37f7685f6528c52c1c6f601d0c37efef6 SHA512 519dc30d6f34bb93ad6ba0e62882950e106cec101bce8566e16dfc167bb576658f8b89385f9137783e6b106e20355bfefe286aedcf1dc31ea468683ab8135971
diff --git a/app-portage/pycargoebuild/pycargoebuild-0.13.4.ebuild b/app-portage/pycargoebuild/pycargoebuild-0.13.4.ebuild
new file mode 100644
index 000000000000..1637c376dad2
--- /dev/null
+++ b/app-portage/pycargoebuild/pycargoebuild-0.13.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A generator for Rust/Cargo ebuilds written in Python"
+HOMEPAGE="
+ https://github.com/projg2/pycargoebuild/
+ https://pypi.org/project/pycargoebuild/
+"
+SRC_URI="
+ https://github.com/projg2/pycargoebuild/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64"
+
+RDEPEND="
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest