summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-09-10 20:04:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-09-10 20:04:23 +0200
commit230cd7c6f0ce6aa20b831f02c4438827ec124a81 (patch)
tree52c872eb317a9aeeb4ef40a90dd4f6c0e4413f1d /app-portage
parentkde-misc/tellico: add 4.0 (diff)
downloadgentoo-230cd7c6f0ce6aa20b831f02c4438827ec124a81.tar.gz
gentoo-230cd7c6f0ce6aa20b831f02c4438827ec124a81.tar.bz2
gentoo-230cd7c6f0ce6aa20b831f02c4438827ec124a81.zip
app-portage/kuroo: Swap bogus kompare:5 RDEPEND for kde-misc/kdiff3
Closes: https://bugs.gentoo.org/938928 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/kuroo/kuroo-1.2.3-r1.ebuild48
-rw-r--r--app-portage/kuroo/kuroo-9999.ebuild4
2 files changed, 50 insertions, 2 deletions
diff --git a/app-portage/kuroo/kuroo-1.2.3-r1.ebuild b/app-portage/kuroo/kuroo-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..24ea23d344a7
--- /dev/null
+++ b/app-portage/kuroo/kuroo-1.2.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.96.0
+inherit ecm
+
+DESCRIPTION="Graphical Portage frontend based on KDE Frameworks"
+HOMEPAGE="https://sourceforge.net/projects/kuroo/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-db/sqlite:3
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/threadweaver-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ app-portage/gentoolkit
+ kde-misc/kdiff3
+"
+
+pkg_postinst() {
+ if ! has_version app-admin/logrotate ; then
+ elog "Installing app-admin/logrotate is recommended to keep"
+ elog "portage's summary.log size reasonable to view in the history page."
+ fi
+
+ ecm_pkg_postinst
+}
diff --git a/app-portage/kuroo/kuroo-9999.ebuild b/app-portage/kuroo/kuroo-9999.ebuild
index 821009e5e6fc..c5795080ee37 100644
--- a/app-portage/kuroo/kuroo-9999.ebuild
+++ b/app-portage/kuroo/kuroo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -35,7 +35,7 @@ DEPEND="
"
RDEPEND="${DEPEND}
app-portage/gentoolkit
- kde-apps/kompare:5
+ kde-misc/kdiff3
"
pkg_postinst() {