summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-05 22:00:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-05 23:50:54 +0100
commitd05d533d5040c87b379b924f87b335963b92259f (patch)
tree8fc3555d383f2ecf3eab4473553e17a4e9f886e3 /app-office
parentdev-java/java-config: add python3_9 to PYTHON_COMPAT. (diff)
downloadgentoo-d05d533d5040c87b379b924f87b335963b92259f.tar.gz
gentoo-d05d533d5040c87b379b924f87b335963b92259f.tar.bz2
gentoo-d05d533d5040c87b379b924f87b335963b92259f.zip
app-office/libreoffice: Fix build with ICU-68
Upstream commit 0b14b9ec55fb2a8dd0ec24e1c03702bc4bbf1878 Reported-by: Mike Lothian <mike@fireburn.co.uk> Closes: https://bugs.gentoo.org/752021 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/files/libreoffice-6.4.7.2-icu-68.patch46
-rw-r--r--app-office/libreoffice/libreoffice-6.4.7.2.ebuild1
2 files changed, 47 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/libreoffice-6.4.7.2-icu-68.patch b/app-office/libreoffice/files/libreoffice-6.4.7.2-icu-68.patch
new file mode 100644
index 000000000000..fe20e3435d2a
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.4.7.2-icu-68.patch
@@ -0,0 +1,46 @@
+From 0b14b9ec55fb2a8dd0ec24e1c03702bc4bbf1878 Mon Sep 17 00:00:00 2001
+From: Rene Engelhard <rene@debian.org>
+Date: Sun, 1 Nov 2020 18:30:49 +0100
+Subject: fix build with ICU 68
+
+use standard true.
+
+/home/rene/LibreOffice/git/master/i18npool/source/calendar/calendar_gregorian.cxx: In member function 'virtual void i18npool::Calendar_gregorian::setLocalDateTime(double)':
+/home/rene/LibreOffice/git/master/i18npool/source/calendar/calendar_gregorian.cxx:363:40: error: 'TRUE' was not declared in this scope
+ 363 | body->getTimeZone().getOffset( fR, TRUE, nZoneOffset, nDSTOffset, status );
+ | ^~~~
+
+/usr/include/unicode/umachine.h says:
+
+@deprecated ICU 68 Use standard "true" instead.
+
+Change-Id: I45d2b0afa6a9043767af5c2cf41ba24377f2cdc4
+Reviewed-on: https://gerrit.libreoffice.org/c/core/+/105057
+Tested-by: Jenkins
+Reviewed-by: Eike Rathke <erack@redhat.com>
+---
+ i18npool/source/calendar/calendar_gregorian.cxx | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/i18npool/source/calendar/calendar_gregorian.cxx b/i18npool/source/calendar/calendar_gregorian.cxx
+index b7ae49fbd96e..59ee46fa0e0f 100644
+--- a/i18npool/source/calendar/calendar_gregorian.cxx
++++ b/i18npool/source/calendar/calendar_gregorian.cxx
+@@ -347,7 +347,14 @@ Calendar_gregorian::setLocalDateTime( double fTimeInDays )
+ "Calendar_gregorian::setLocalDateTime: " << std::fixed << fM << " rounded to " << fR);
+ int32_t nZoneOffset, nDSTOffset;
+ UErrorCode status = U_ZERO_ERROR;
+- body->getTimeZone().getOffset( fR, TRUE, nZoneOffset, nDSTOffset, status );
++ body->getTimeZone().getOffset( fR,
++#if U_ICU_VERSION_MAJOR_NUM >= 68
++ true,
++#else
++ TRUE,
++#endif
++ nZoneOffset, nDSTOffset, status );
++
+ if ( !U_SUCCESS(status) ) throw ERROR;
+ status = U_ZERO_ERROR;
+ body->setTime( fR - (nZoneOffset + nDSTOffset), status );
+--
+cgit v1.2.1
diff --git a/app-office/libreoffice/libreoffice-6.4.7.2.ebuild b/app-office/libreoffice/libreoffice-6.4.7.2.ebuild
index 0d74d54e9b12..e1f48dbe39fe 100644
--- a/app-office/libreoffice/libreoffice-6.4.7.2.ebuild
+++ b/app-office/libreoffice/libreoffice-6.4.7.2.ebuild
@@ -274,6 +274,7 @@ PATCHES=(
# git master
"${FILESDIR}/${PN}-6.4.3.2-boost-1.73.patch" # bug 721806
"${FILESDIR}/${PN}-6.4.6.2-llvm-10.patch" # bug 713574
+ "${FILESDIR}/${P}-icu-68.patch" # bug 752021
)
S="${WORKDIR}/${PN}-${MY_PV}"