summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-08-09 22:17:11 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-08-09 22:17:11 +0100
commit9b0db9696485db36116cb171c850b195b86800ee (patch)
treefd810a3f316bc08b07fa04363710b8423906a1e7 /app-office
parentsys-cluster/galera: Stabilize 26.4.19 amd64, #937634 (diff)
downloadgentoo-9b0db9696485db36116cb171c850b195b86800ee.tar.gz
gentoo-9b0db9696485db36116cb171c850b195b86800ee.tar.bz2
gentoo-9b0db9696485db36116cb171c850b195b86800ee.zip
app-office/glabels: Fix building with GCC 14
Closes: https://bugs.gentoo.org/921144 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/glabels/files/glabels-gcc14.patch27
-rw-r--r--app-office/glabels/glabels-3.4.1-r1.ebuild3
2 files changed, 29 insertions, 1 deletions
diff --git a/app-office/glabels/files/glabels-gcc14.patch b/app-office/glabels/files/glabels-gcc14.patch
new file mode 100644
index 000000000000..61f21ed9f2ff
--- /dev/null
+++ b/app-office/glabels/files/glabels-gcc14.patch
@@ -0,0 +1,27 @@
+diff -Naur a/src/pixbuf-cache.c b/src/pixbuf-cache.c
+--- a/src/pixbuf-cache.c 2016-01-24 02:06:18.000000000 +0000
++++ b/src/pixbuf-cache.c 2024-08-09 22:11:46.908878425 +0100
+@@ -125,7 +125,7 @@
+ record = g_new0 (CacheRecord, 1);
+ record->key = g_strdup (name);
+ record->references = 0; /* Nobody has referenced it yet. */
+- record->pixbuf = g_object_ref (G_OBJECT (pixbuf));
++ record->pixbuf = pixbuf;
+
+ g_hash_table_insert (pixbuf_cache, record->key, record);
+
+diff -Naur a/src/ui-commands.c b/src/ui-commands.c
+--- a/src/ui-commands.c 2016-01-24 02:06:18.000000000 +0000
++++ b/src/ui-commands.c 2024-08-09 22:10:18.466271055 +0100
+@@ -1071,9 +1071,10 @@
+ } else {
+
+ window->merge_dialog =
++ GL_MERGE_PROPERTIES_DIALOG(
+ g_object_ref (
+ gl_merge_properties_dialog_new (GL_VIEW(window->view)->label,
+- GTK_WINDOW(window)) );
++ GTK_WINDOW(window)) ));
+
+ g_signal_connect (G_OBJECT(window->merge_dialog), "destroy",
+ G_CALLBACK (gtk_widget_destroyed),
diff --git a/app-office/glabels/glabels-3.4.1-r1.ebuild b/app-office/glabels/glabels-3.4.1-r1.ebuild
index cf1bc346deb7..029622812f7a 100644
--- a/app-office/glabels/glabels-3.4.1-r1.ebuild
+++ b/app-office/glabels/glabels-3.4.1-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
inherit gnome2
DESCRIPTION="Program for creating labels and business cards"
-HOMEPAGE="https://glabels.org/"
+HOMEPAGE="https://github.com/jimevins/glabels-qt"
LICENSE="GPL-3+ LGPL-3+ CC-BY-SA-3.0 MIT"
SLOT="0"
@@ -35,6 +35,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/glabels-externs.patch # Fix compilation with -fno-common/gcc10; patch from Fedora
+ "${FILESDIR}"/glabels-gcc14.patch
)
src_configure() {