summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-12 03:47:31 +0100
committerSam James <sam@gentoo.org>2022-07-12 04:03:14 +0100
commit9473a1d20aa819dfa43544b2b14dd27772ca43fc (patch)
tree6e532c6c736eab474ba113e3198e845cdbcbc3e8 /app-office/gtg
parentapp-office/gtg: drop 0.4.0 (diff)
downloadgentoo-9473a1d20aa819dfa43544b2b14dd27772ca43fc.tar.gz
gentoo-9473a1d20aa819dfa43544b2b14dd27772ca43fc.tar.bz2
gentoo-9473a1d20aa819dfa43544b2b14dd27772ca43fc.zip
app-office/gtg: use canonical phase ordering
To match execution, per devmanual. See: https://github.com/gentoo/gentoo/pull/26269 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-office/gtg')
-rw-r--r--app-office/gtg/gtg-0.6.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-office/gtg/gtg-0.6.ebuild b/app-office/gtg/gtg-0.6.ebuild
index e55a20f164bf..7fe456bf3945 100644
--- a/app-office/gtg/gtg-0.6.ebuild
+++ b/app-office/gtg/gtg-0.6.ebuild
@@ -46,13 +46,13 @@ BDEPEND="
)
"
+src_test() {
+ sed -e "s|@VCS_TAG@|${PV}|" GTG/core/info.py.in > GTG/core/info.py || die
+ nosetests -v || die
+}
+
src_install() {
meson_src_install
python_fix_shebang "${ED}"/usr/bin/gtg
python_optimize
}
-
-src_test() {
- sed -e "s|@VCS_TAG@|${PV}|" GTG/core/info.py.in > GTG/core/info.py || die
- nosetests -v || die
-}