summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-09-25 08:56:13 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-09-25 10:02:10 +0200
commitd7b9ae6c613e796387092d03d4d85d7b6dc2ca62 (patch)
tree1f8430e3733e3a7f1add964f112c12a34622dc74 /app-mobilephone
parentapp-mobilephone/scrcpy: drop 2.4, 2.5 (diff)
downloadgentoo-d7b9ae6c613e796387092d03d4d85d7b6dc2ca62.tar.gz
gentoo-d7b9ae6c613e796387092d03d4d85d7b6dc2ca62.tar.bz2
gentoo-d7b9ae6c613e796387092d03d4d85d7b6dc2ca62.zip
app-mobilephone/scrcpy: add 2.7
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/scrcpy/Manifest2
-rw-r--r--app-mobilephone/scrcpy/scrcpy-2.7.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-mobilephone/scrcpy/Manifest b/app-mobilephone/scrcpy/Manifest
index a1d4c23fe65f..148c40d9cfe4 100644
--- a/app-mobilephone/scrcpy/Manifest
+++ b/app-mobilephone/scrcpy/Manifest
@@ -1,2 +1,4 @@
DIST scrcpy-2.6.1.tar.gz 419739 BLAKE2B 96fd98df68b623f0fa5907559027a1257dc781e674ff458901e551e96f020d1a31bc90353551defb3947992d2d13e73c6c3897d59089cac68ba3851cd850f108 SHA512 bea16a4b38a8044c4a6cc9135f1d261194d9d6ca5cea70eff77d92e706bbfa6cdd0a394790b69bbb3b05eb87e206ee0fc40d2afc52b554cda7d15c6e78485641
+DIST scrcpy-2.7.tar.gz 430160 BLAKE2B 58eb8464fc05cecef7b28f825e0608e9336ef0a2c9db0936fa3ba50a5fc5a9536252f5c1570a270b0df0a7f8a7643a6a0953f433ed84495cc55d4a21a9788325 SHA512 8029fa9b1ad24746fd56f10398445870e26256160b742be46da2c5c9a1a0d8b2e4301a9f65ca09b75a0162555b4345d30cbede8d07f6f89dc66befab87dfe5b7
DIST scrcpy-server-v2.6.1 71112 BLAKE2B 41afffcaa0e6373ec1f69c89a112316b6153a4bff3da70f6c5925030d635bff83920392f5e658dc53757883ff222a40e6584a608d8fcbc4bc9c799d625b7b4f1 SHA512 7ae266670c84eced334af4c980e4d35f0ccf17d26d26d529ec977fd6f747c6a3086de5abaa7e1b88a71bb60648b124bf5e5969ab54f8ba05f00c940ab6424134
+DIST scrcpy-server-v2.7 71200 BLAKE2B 968d7454e4e5702eecd439256378c7b28f234d9ed4ff97d3073505cfaafe4554a70445a8483bf062de45b9e0045974de1a1610e8d4a21f168ef2b8be336f9a75 SHA512 dbb9ec702a7c01d147554aa9a2063c48bd5a9d2bac747fadc7bacca93c257edbc5b30cae1ba412f43d1d3f481fa080edee2ddbfa3e0f2d50a89eab95febf1c9b
diff --git a/app-mobilephone/scrcpy/scrcpy-2.7.ebuild b/app-mobilephone/scrcpy/scrcpy-2.7.ebuild
new file mode 100644
index 000000000000..ef5acfc0b38d
--- /dev/null
+++ b/app-mobilephone/scrcpy/scrcpy-2.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Display and control your Android device"
+HOMEPAGE="https://github.com/Genymobile/scrcpy"
+# Source code and server part on Android device
+SRC_URI="
+ https://github.com/Genymobile/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Genymobile/${PN}/releases/download/v${PV}/${PN}-server-v${PV}
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ media-libs/libsdl2[X]
+ media-video/ffmpeg:=
+ virtual/libusb:1
+"
+# Manual install for ppc64 until bug #723528 is fixed
+RDEPEND="
+ ${DEPEND}
+ !ppc64? ( dev-util/android-tools )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dprebuilt_server="${DISTDIR}/${PN}-server-v${PV}"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+
+ einfo "If you use pipewire because of a problem with libsdl2 it is possible that"
+ einfo "scrcpy will not start, in which case start the program by exporting the"
+ einfo "environment variable SDL_AUDIODRIVER=pipewire."
+ einfo "For more information see https://github.com/Genymobile/scrcpy/issues/3864."
+}