summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuje Mihanović <duje.mihanovic@skole.hr>2022-05-20 20:39:56 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-05-26 15:58:04 +0300
commit8782b401df0e41a032344163bf9e15d37ef47084 (patch)
treea30b066f4d3e2a4580f6e378ec651303fa91553a /app-mobilephone/heimdall
parentapp-mobilephone/heimdall: add maintainer, update upstream (diff)
downloadgentoo-8782b401df0e41a032344163bf9e15d37ef47084.tar.gz
gentoo-8782b401df0e41a032344163bf9e15d37ef47084.tar.bz2
gentoo-8782b401df0e41a032344163bf9e15d37ef47084.zip
app-mobilephone/heimdall: add 2.0.1, update 9999 repo URL
Signed-off-by: Duje Mihanović <duje.mihanovic@skole.hr> Closes: https://github.com/gentoo/gentoo/pull/25578 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-mobilephone/heimdall')
-rw-r--r--app-mobilephone/heimdall/Manifest1
-rw-r--r--app-mobilephone/heimdall/heimdall-2.0.1.ebuild48
-rw-r--r--app-mobilephone/heimdall/heimdall-9999.ebuild14
3 files changed, 56 insertions, 7 deletions
diff --git a/app-mobilephone/heimdall/Manifest b/app-mobilephone/heimdall/Manifest
index b2feeb301ec7..830bffde4690 100644
--- a/app-mobilephone/heimdall/Manifest
+++ b/app-mobilephone/heimdall/Manifest
@@ -1 +1,2 @@
DIST heimdall-1.4.2.tar.gz 5486693 BLAKE2B 213bfa5bb7ede8d418847916a5ec16c17e4dec7fcb07de296d96e16c929634167afb57e13cee0e8a6e42fbbddcd2f2e0f5069cfbc3e8c3b5721d2d303ef48407 SHA512 c554662f9ccb763a8e9867a0c563618879d2533af985d44db3c237d3ee51add44c1681d13b1a83b72b30ba6e5b32d7c2f9c02b31114c67c5fbe01cbb010acfe7
+DIST heimdall-2.0.1.tar.gz 83642 BLAKE2B 29cd784a4ea4c25f9670d27c306ca95d60d7ad8a11175d2ee835a0cf1e7fc5eb179aa4e49c5e05e280ed5ce475a9e66e56b48444dd4b3b93ea8cb173e3d18060 SHA512 f6df4551702a7ad7688018d60569b8b94f20be4f78a9b4bf5f6e89396ed43cd7519617ef1f420b41bbfeec8b51ae636759a7b90443d3d5945cd8744b43e2d0ef
diff --git a/app-mobilephone/heimdall/heimdall-2.0.1.ebuild b/app-mobilephone/heimdall/heimdall-2.0.1.ebuild
new file mode 100644
index 000000000000..d0b54138bb63
--- /dev/null
+++ b/app-mobilephone/heimdall/heimdall-2.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake udev
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://git.sr.ht/~grimler/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm64"
+ S="${WORKDIR}/Heimdall-v${PV}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~grimler/Heimdall"
+fi
+
+DESCRIPTION="Tool suite used to flash firmware onto Samsung devices"
+HOMEPAGE="https://git.sr.ht/~grimler/Heimdall https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gui"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/libusb:1=
+ gui? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_FRONTEND=$(usex !gui)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ dobin "${BUILD_DIR}"/bin/heimdall
+ use gui && dobin "${BUILD_DIR}"/bin/heimdall-frontend
+ udev_dorules heimdall/60-heimdall.rules
+ dodoc README.md Linux/README
+}
diff --git a/app-mobilephone/heimdall/heimdall-9999.ebuild b/app-mobilephone/heimdall/heimdall-9999.ebuild
index e4026eb23735..d0b54138bb63 100644
--- a/app-mobilephone/heimdall/heimdall-9999.ebuild
+++ b/app-mobilephone/heimdall/heimdall-9999.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake udev
if [[ ${PV} != 9999 ]]; then
- SRC_URI="https://github.com/Benjamin-Dobell/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/Heimdall-${PV}"
+ SRC_URI="https://git.sr.ht/~grimler/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm64"
+ S="${WORKDIR}/Heimdall-v${PV}"
else
inherit git-r3
- EGIT_REPO_URI="https://github.com/Benjamin-Dobell/Heimdall.git"
+ EGIT_REPO_URI="https://git.sr.ht/~grimler/Heimdall"
fi
DESCRIPTION="Tool suite used to flash firmware onto Samsung devices"
-HOMEPAGE="https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
+HOMEPAGE="https://git.sr.ht/~grimler/Heimdall https://glassechidna.com.au/heimdall/ https://github.com/Benjamin-Dobell/Heimdall"
LICENSE="MIT"
SLOT="0"