summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/heimdall
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/heimdall')
-rw-r--r--app-mobilephone/heimdall/Manifest2
-rw-r--r--app-mobilephone/heimdall/heimdall-1.4.0.ebuild63
-rw-r--r--app-mobilephone/heimdall/heimdall-1.4.1.ebuild62
-rw-r--r--app-mobilephone/heimdall/heimdall-9999.ebuild58
-rw-r--r--app-mobilephone/heimdall/metadata.xml11
5 files changed, 196 insertions, 0 deletions
diff --git a/app-mobilephone/heimdall/Manifest b/app-mobilephone/heimdall/Manifest
new file mode 100644
index 000000000000..45d58a5529a8
--- /dev/null
+++ b/app-mobilephone/heimdall/Manifest
@@ -0,0 +1,2 @@
+DIST heimdall-1.4.0.tar.gz 6565316 SHA256 13f5edff2fc857cf7d82708a2ac9ad1f6d2f5d6a2e5d84587f55f62583d60531 SHA512 ae6c55af97fe95587b89cce90e75fd3b236fd8ac0d506112c9c143fb1d0982aac6d1bef7a6c6635b547148ac4913aeb4215ed9c7c8084fd0912010c5ad9604ee WHIRLPOOL b4c64a755d2f3577f894e22633e11cf60323d028b89e8117fa2c6cbedf7b55d9227cb17017d966d3d48fb56958a11ce87f3334aafedfcae57e6928ef42d8c121
+DIST heimdall-1.4.1.tar.gz 6358720 SHA256 f0a6e4b5bf806fe4ab5413dd869817b600bcd339b642ff46ec0c5fe69adf7230 SHA512 2f1f49b0ad7bd5f4359893359b26024fe0cce84afed3878e42d902eb4dee487a44e351247d57e4af143ad728abd6c664df688246fcf7b96b9f3841cd16594296 WHIRLPOOL 13fa7c40f66c17010e0aca9c96e87ed34196ae2fa4c2944c63afba7df619620e154692b3846cafecf5b8cf6896e7f7a92d47e255c87421a57494f5747c6cedee
diff --git a/app-mobilephone/heimdall/heimdall-1.4.0.ebuild b/app-mobilephone/heimdall/heimdall-1.4.0.ebuild
new file mode 100644
index 000000000000..8ee2b8206954
--- /dev/null
+++ b/app-mobilephone/heimdall/heimdall-1.4.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils qt4-r2 udev
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/Benjamin-Dobell/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/Heimdall-${PV}"
+else
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/Benjamin-Dobell/Heimdall.git
+ https://github.com/Benjamin-Dobell/Heimdall.git"
+fi
+
+DESCRIPTION="Tool suite used to flash firmware onto Samsung Galaxy S devices"
+HOMEPAGE="http://www.glassechidna.com.au/products/heimdall/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="qt4"
+
+# virtual/libusb is not precise enough
+RDEPEND=">=dev-libs/libusb-1.0.18:1=
+ qt4? ( dev-qt/qtcore:4= dev-qt/qtgui:4= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm -r libusbx-1.0 || die
+ cd "${S}/heimdall" || die
+ edos2unix configure.ac Makefile.am || die
+ sed -i -e /sudo/d Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}/libpit" || die
+ econf
+
+ cd "${S}/heimdall" || die
+ econf
+
+ if use qt4; then
+ cd "${S}/heimdall-frontend" || die
+ eqmake4 heimdall-frontend.pro OUTPUTDIR=/usr/bin || die
+ fi
+}
+
+src_compile() {
+ emake -C libpit
+ emake -C heimdall
+ use qt4 && emake -C heimdall-frontend
+}
+
+src_install() {
+ emake -C heimdall DESTDIR="${D}" udevrulesdir="$(get_udevdir)/rules.d" install
+ dodoc Linux/README
+ use qt4 && emake -C heimdall-frontend INSTALL_ROOT="${D}" install
+}
diff --git a/app-mobilephone/heimdall/heimdall-1.4.1.ebuild b/app-mobilephone/heimdall/heimdall-1.4.1.ebuild
new file mode 100644
index 000000000000..c01aa853002a
--- /dev/null
+++ b/app-mobilephone/heimdall/heimdall-1.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils qt4-r2 udev
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/Benjamin-Dobell/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/Heimdall-${PV}"
+else
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/Benjamin-Dobell/Heimdall.git
+ https://github.com/Benjamin-Dobell/Heimdall.git"
+fi
+
+DESCRIPTION="Tool suite used to flash firmware onto Samsung Galaxy S devices"
+HOMEPAGE="http://www.glassechidna.com.au/products/heimdall/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="qt4"
+
+# virtual/libusb is not precise enough
+RDEPEND=">=dev-libs/libusb-1.0.18:1=
+ qt4? ( dev-qt/qtcore:4= dev-qt/qtgui:4= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm -r libusb-1.0 || die
+ cd "${S}/heimdall" || die
+ edos2unix configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}/libpit" || die
+ econf
+
+ cd "${S}/heimdall" || die
+ econf
+
+ if use qt4; then
+ cd "${S}/heimdall-frontend" || die
+ eqmake4 heimdall-frontend.pro OUTPUTDIR=/usr/bin || die
+ fi
+}
+
+src_compile() {
+ emake -C libpit
+ emake -C heimdall
+ use qt4 && emake -C heimdall-frontend
+}
+
+src_install() {
+ emake -C heimdall DESTDIR="${D}" udevrulesdir="$(get_udevdir)/rules.d" install
+ dodoc Linux/README
+ use qt4 && emake -C heimdall-frontend INSTALL_ROOT="${D}" install
+}
diff --git a/app-mobilephone/heimdall/heimdall-9999.ebuild b/app-mobilephone/heimdall/heimdall-9999.ebuild
new file mode 100644
index 000000000000..74f397125c3d
--- /dev/null
+++ b/app-mobilephone/heimdall/heimdall-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_IN_SOURCE_BUILD="true"
+
+inherit autotools eutils cmake-utils udev
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/Benjamin-Dobell/Heimdall/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/Heimdall-${PV}"
+else
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/Benjamin-Dobell/Heimdall.git
+ https://github.com/Benjamin-Dobell/Heimdall.git"
+fi
+
+DESCRIPTION="Tool suite used to flash firmware onto Samsung Galaxy S devices"
+HOMEPAGE="http://www.glassechidna.com.au/products/heimdall/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="qt5 static-libs"
+
+# virtual/libusb is not precise enough
+RDEPEND=">=dev-libs/libusb-1.0.18:1=[static-libs=]
+ qt5? ( dev-qt/qtwidgets:5= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ if ! use qt5 ; then
+ sed '/heimdall-frontend/d' \
+ -i CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ cmake-utils_src_configure \
+ $(cmake-utils_use_use static-libs STATIC_LIBS)
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ # cmake-utils_src_install doesn't work
+ dobin "${S}"/bin/${PN}
+ use qt5 && dobin "${S}"/bin/${PN}-frontend
+
+ insinto $(get_udevdir)/rules.d
+ doins "${S}"/${PN}/60-${PN}.rules
+ dodoc Linux/README
+}
diff --git a/app-mobilephone/heimdall/metadata.xml b/app-mobilephone/heimdall/metadata.xml
new file mode 100644
index 000000000000..ca5c05ae6a0f
--- /dev/null
+++ b/app-mobilephone/heimdall/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Benjamin-Dobell/Heimdall</remote-id>
+ </upstream>
+</pkgmetadata>