summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-11-28 21:16:52 +0100
committerSebastian Pipping <sping@gentoo.org>2022-11-28 21:17:44 +0100
commitfc1142272a55bff1fd09c4f3547a0e0b4d5c89a0 (patch)
tree2682b15b426fdc5fe7369bee00a554e272133cda /app-misc
parentapp-misc/resolve-march-native: Drop old (diff)
downloadgentoo-fc1142272a55bff1fd09c4f3547a0e0b4d5c89a0.tar.gz
gentoo-fc1142272a55bff1fd09c4f3547a0e0b4d5c89a0.tar.bz2
gentoo-fc1142272a55bff1fd09c4f3547a0e0b4d5c89a0.zip
app-misc/resolve-march-native: Python 3.11 + DistutilsNonPEP517Build
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/resolve-march-native/resolve-march-native-2.1.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-misc/resolve-march-native/resolve-march-native-2.1.0-r1.ebuild b/app-misc/resolve-march-native/resolve-march-native-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..62a63562c42f
--- /dev/null
+++ b/app-misc/resolve-march-native/resolve-march-native-2.1.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Resolve GCC flag -march=native"
+HOMEPAGE="https://github.com/hartwork/resolve-march-native"
+SRC_URI="https://github.com/hartwork/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sys-devel/gcc-4.2"
+
+distutils_enable_tests pytest