summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-09-06 19:39:13 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-09-06 19:39:13 +0200
commit9900a9f8022569e9368ee056207dbc305af3a6ac (patch)
tree0b6196fba74e3540f48d69d32f78c7f45f7b1003 /app-misc
parentdev-util/clair: Version bump to 2.0.5 (diff)
downloadgentoo-9900a9f8022569e9368ee056207dbc305af3a6ac.tar.gz
gentoo-9900a9f8022569e9368ee056207dbc305af3a6ac.tar.bz2
gentoo-9900a9f8022569e9368ee056207dbc305af3a6ac.zip
app-misc/mkcert: Version bump to 1.1.2
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/mkcert/Manifest1
-rw-r--r--app-misc/mkcert/mkcert-1.1.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/mkcert/Manifest b/app-misc/mkcert/Manifest
index 8c707b9f9536..0227a5921116 100644
--- a/app-misc/mkcert/Manifest
+++ b/app-misc/mkcert/Manifest
@@ -1 +1,2 @@
DIST mkcert-1.0.1.tar.gz 1695474 BLAKE2B eeef86a3e626f044c7b83d86be55082ce256752d834bf1388890db18f74678df57f2fc0050874dd4ff9ec4b849aa5b8d339e09e6af7e08a8f0b5236e0ac7aa09 SHA512 9e4ebadf19134fee7bf637fbb402df46a70d1f99ad06685a6a49da929fdd61b1ae9bea6b3f287201f488aec90505c60a58b454abb2efe584114d814023789600
+DIST mkcert-1.1.2.tar.gz 374244 BLAKE2B 3d9dd700e77ae6eae693bed51ae027fba409880f2c0f8fe1d5eb3c4af1e85f03784c0f6b55a384117c8ba8949ba0f061911998846f8c7ac3fddaa9e4dee567f5 SHA512 6015964915088914c0c208c47a41142b4b69e1e0c6e890422fe07c0dee2fb7c8a1ac04b9efba8a913de35ef3f46d3c8ee96941257eefbceb1c1885a67e1255da
diff --git a/app-misc/mkcert/mkcert-1.1.2.ebuild b/app-misc/mkcert/mkcert-1.1.2.ebuild
new file mode 100644
index 000000000000..0176c20c9259
--- /dev/null
+++ b/app-misc/mkcert/mkcert-1.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/FiloSottile/mkcert"
+
+inherit golang-build golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="A zero-config tool to make locally trusted development certificates"
+HOMEPAGE="https://github.com/FiloSottile/mkcert"
+SRC_URI="https://github.com/FiloSottile/mkcert/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go install -v ${EGO_PN} || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/mkcert
+ dodoc src/${EGO_PN}/README.md
+}