summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/pysmssend
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/pysmssend')
-rw-r--r--app-misc/pysmssend/Manifest1
-rw-r--r--app-misc/pysmssend/metadata.xml11
-rw-r--r--app-misc/pysmssend/pysmssend-1.48-r1.ebuild49
-rw-r--r--app-misc/pysmssend/pysmssend-1.48.ebuild45
-rw-r--r--app-misc/pysmssend/pysmssend-9999.ebuild63
5 files changed, 169 insertions, 0 deletions
diff --git a/app-misc/pysmssend/Manifest b/app-misc/pysmssend/Manifest
new file mode 100644
index 000000000000..0c2bda6266a3
--- /dev/null
+++ b/app-misc/pysmssend/Manifest
@@ -0,0 +1 @@
+DIST pysmssend-1.48.tar.gz 58172 SHA256 8b8744eb0625d6f65632c56f58a304c5c9825d417d81f523024629ea611520ce SHA512 d1d08e11bb4a5f450a98e9bf6292ce65edb61e0610e085dd79dcb80fd8ce1d15f7350797a0150eb6ddcc0116c17e3290f2790632eb7f54ab66efdcf662022088 WHIRLPOOL 29d3a06ec73f3b667228aa4d3e8d710607fb313331c41470b7aeda4fcdb265ae31feed0714b3a75a110d289d03b87047d3600121c2e82dac0c7ed2cc288fdd1b
diff --git a/app-misc/pysmssend/metadata.xml b/app-misc/pysmssend/metadata.xml
new file mode 100644
index 000000000000..5e3a61a90139
--- /dev/null
+++ b/app-misc/pysmssend/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-misc/pysmssend/pysmssend-1.48-r1.ebuild b/app-misc/pysmssend/pysmssend-1.48-r1.ebuild
new file mode 100644
index 000000000000..9916e17ba2a8
--- /dev/null
+++ b/app-misc/pysmssend/pysmssend-1.48-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python Application for sending sms over multiple ISPs"
+HOMEPAGE="http://pysmssend.silverarrow.org/"
+SRC_URI="http://pysmssend.silverarrow.org/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4"
+
+DEPEND=">dev-python/mechanize-0.1.7b[${PYTHON_USEDEP}]
+ qt4? ( dev-python/PyQt4[X,${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+python_install() {
+ distutils-r1_python_install
+
+ python_doscript pysmssendcmd
+ if use qt4; then
+ python_doscript pysmssend
+ else
+ ln -s pysmssendcmd "${D}$(python_get_scriptdir)"/pysmssend || die
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ if use qt4; then
+ insinto /usr/share/${PN}/Icons
+ doins Icons/*
+ doicon Icons/pysmssend.png
+ make_desktop_entry pysmssend pySMSsend pysmssend \
+ "Applications;Network"
+ else
+ dosym pysmssendcmd /usr/bin/pysmssend
+ fi
+ dodoc README AUTHORS TODO
+}
diff --git a/app-misc/pysmssend/pysmssend-1.48.ebuild b/app-misc/pysmssend/pysmssend-1.48.ebuild
new file mode 100644
index 000000000000..08381ddd3d8f
--- /dev/null
+++ b/app-misc/pysmssend/pysmssend-1.48.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python Application for sending sms over multiple ISPs"
+HOMEPAGE="http://pysmssend.silverarrow.org/"
+SRC_URI="http://pysmssend.silverarrow.org/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="qt4"
+
+DEPEND=">dev-python/mechanize-0.1.7b
+ qt4? ( dev-python/PyQt4[X] )"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="pysmssendmod"
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ distutils_src_install
+ if use qt4; then
+ insinto /usr/share/${PN}/Icons || die "insinto failed"
+ doins Icons/* || die "doins failed"
+ doicon Icons/pysmssend.png || die "doicon failed"
+ dobin pysmssend pysmssendcmd || die "failed to create executables"
+ make_desktop_entry pysmssend pySMSsend pysmssend \
+ "Applications;Network" || die "make_desktop_entry failed"
+ else
+ dobin pysmssendcmd || die "failed to create executable"
+ dosym pysmssendcmd /usr/bin/pysmssend || die "dosym failed"
+ fi
+ dodoc README AUTHORS TODO || die "dodoc failed"
+}
diff --git a/app-misc/pysmssend/pysmssend-9999.ebuild b/app-misc/pysmssend/pysmssend-9999.ebuild
new file mode 100644
index 000000000000..46c91f583534
--- /dev/null
+++ b/app-misc/pysmssend/pysmssend-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+EGIT_REPO_URI="git://github.com/hwoarang/${PN}.git
+ http://github.com/hwoarang/${PN}.git"
+
+inherit distutils eutils git-2
+
+DESCRIPTION="Python Application for sending sms over multiple ISPs"
+HOMEPAGE="http://pysmssend.silverarrow.org/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="qt4"
+
+DEPEND=">=dev-python/mechanize-0.1.9
+ qt4? ( >=dev-python/PyQt4-4.3[X] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/pysmssend"
+
+PYTHON_MODNAME="pysmssendmod"
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ distutils_src_install
+ if use qt4; then
+ insinto /usr/share/${PN}/Icons || die "insinto failed"
+ doins Icons/* || die "doins failed"
+ doicon Icons/pysmssend.png || die "doicon failed"
+ dobin pysmssend pysmssendcmd || die "failed to create executables"
+ domenu ${PN}.desktop || die "make_desktop_entry failed"
+ else
+ dobin pysmssendcmd || die "failed to create executable"
+ dosym pysmssendcmd /usr/bin/pysmssend || die "dosym failed"
+ fi
+ dodoc README AUTHORS TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ elog
+ elog "${PN} can use dev-python/python-gnupg"
+ elog "for keeping your account data encrypted"
+ elog "and secured. If you want to use it,"
+ elog "first install dev-python/python-gnupg using"
+ elog "emerge -av dev-python/python/gnupg"
+ elog "and then edit your ~/.pysmssend/config"
+ elog "file and set:"
+ elog
+ elog "pysmssend_gpg_support=1"
+ elog "pysmssend_gpg_key=<your_gpg_key_id>"
+ elog
+}