summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-21 23:21:43 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-21 23:31:57 +0200
commit4a7512992387fc6cf8e009261776b75362754e89 (patch)
tree0f8b23d87937cc1c6848d345507726ac032f112f /app-misc/mvcase
parentmedia-gfx/openscad: Cleanup Qt4-based (diff)
downloadgentoo-4a7512992387fc6cf8e009261776b75362754e89.tar.gz
gentoo-4a7512992387fc6cf8e009261776b75362754e89.tar.bz2
gentoo-4a7512992387fc6cf8e009261776b75362754e89.zip
app-misc/mvcase: EAPI 6 bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-misc/mvcase')
-rw-r--r--app-misc/mvcase/mvcase-0.1-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/mvcase/mvcase-0.1-r2.ebuild b/app-misc/mvcase/mvcase-0.1-r2.ebuild
new file mode 100644
index 000000000000..568fed8c4a02
--- /dev/null
+++ b/app-misc/mvcase/mvcase-0.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A modified version of mv, used to convert filenames to lower/upper case"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/utils/file"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="dev-libs/shhopt"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-includes.patch"
+ "${FILESDIR}/${P}-flags.patch"
+)
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}