summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2020-12-17 18:57:42 +0100
committerAmy Liffey <amynka@gentoo.org>2020-12-17 19:02:49 +0100
commitc39303f08a622fdd28e36b6fc642bfacda88f69a (patch)
treed5d9f8485f429103c615a30e3f72e1cb690e196b /app-misc/khal
parentsys-apps/qcontrol: migrate to lua-single.eclass (diff)
downloadgentoo-c39303f08a622fdd28e36b6fc642bfacda88f69a.tar.gz
gentoo-c39303f08a622fdd28e36b6fc642bfacda88f69a.tar.bz2
gentoo-c39303f08a622fdd28e36b6fc642bfacda88f69a.zip
app-misc/khal: version bump 0.10.2
Closes: https://bugs.gentoo.org/742461 Package-Manager: Portage-3.0.8, Repoman-2.3.23 Signed-off-by: Amy Liffey <amynka@gentoo.org>
Diffstat (limited to 'app-misc/khal')
-rw-r--r--app-misc/khal/Manifest1
-rw-r--r--app-misc/khal/khal-0.10.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/khal/Manifest b/app-misc/khal/Manifest
index 6c5897b1b924..d201adab37f0 100644
--- a/app-misc/khal/Manifest
+++ b/app-misc/khal/Manifest
@@ -1 +1,2 @@
DIST khal-0.10.1.tar.gz 173636 BLAKE2B 97158bc78dfbda3a3555df3588c61f6a5e8b20d71921099a74ba997eb7ccef05ed931e930afbb09f9c125f3e0e782143dd2cdf4d0da6bd09952765b9117d6ac4 SHA512 5b81a60099c201fa112ab17740b73edb17b29efa1548086766d57d9d595451e7d779aad5a2ce7a2afc78050116782ff6696c4bd284021a5e12c87fe361d15e47
+DIST khal-0.10.2.tar.gz 182534 BLAKE2B 0c7c4ab1234ebe90ef9ad8291f2a0087a3f6a60d25f5426445eedadb25f236b3598dacc051e959a108ad472efc56628bf7ba11ed714c885d956f1a8f905029ca SHA512 e15449b73175190f02b6fe5774a8feef8a5390966da3836624c94a044d146cc6e8a73985d991042fbb617f736c6759ded387a65292529e71f5b2f34bc80a686e
diff --git a/app-misc/khal/khal-0.10.2.ebuild b/app-misc/khal/khal-0.10.2.ebuild
new file mode 100644
index 000000000000..aab3b6993446
--- /dev/null
+++ b/app-misc/khal/khal-0.10.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A CalDAV based calendar"
+HOMEPAGE="http://lostpackets.de/khal/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
+ >=dev-python/click-log-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/icalendar-4.0.3[${PYTHON_USEDEP}]
+ >=dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-1.0[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ zsh-completion? ( app-shells/zsh )"
+DEPEND=">dev-python/setuptools_scm-1.12.0[${PYTHON_USEDEP}]
+ dev-python/vdirsyncer[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.rst README.rst khal.conf.sample )
+
+src_install() {
+ distutils-r1_src_install
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/__khal
+ fi
+}