summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucian Poston <lucianposton@pm.me>2018-08-01 17:10:59 -0700
committerMichał Górny <mgorny@gentoo.org>2018-08-22 22:31:15 +0200
commitd773c7c200ee0debe560d131081009200b87cc7d (patch)
tree39d4140f48c70618f4d1c1b34cd66d138d2141fc /app-misc/imgurbash2/imgurbash2-9999.ebuild
parentnet-misc/openssh: drop unused versionator eclass (diff)
downloadgentoo-d773c7c200ee0debe560d131081009200b87cc7d.tar.gz
gentoo-d773c7c200ee0debe560d131081009200b87cc7d.tar.bz2
gentoo-d773c7c200ee0debe560d131081009200b87cc7d.zip
app-misc/imgurbash2: New package
Closes: https://bugs.gentoo.org/662620 Closes: https://github.com/gentoo/gentoo/pull/9416 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-misc/imgurbash2/imgurbash2-9999.ebuild')
-rw-r--r--app-misc/imgurbash2/imgurbash2-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/imgurbash2/imgurbash2-9999.ebuild b/app-misc/imgurbash2/imgurbash2-9999.ebuild
new file mode 100644
index 000000000000..076690d530e5
--- /dev/null
+++ b/app-misc/imgurbash2/imgurbash2-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ram-on/imgurbash2.git"
+else
+ SRC_URI="https://github.com/ram-on/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Bash script that uploads/deletes images to/from imgur"
+HOMEPAGE="https://github.com/ram-on/imgurbash2"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="
+ net-misc/curl
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+"
+
+src_install() {
+ einstalldocs
+ dobin imgurbash2
+}