summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gantner <gentoo@nephros.org>2019-11-14 13:05:02 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-04 19:41:12 +0200
commitfd03bbd59bde96554286d52902bd6cd2209ca528 (patch)
tree8c5c9a23789d655834234b35db68eb06147beb4f /app-misc/hodie/hodie-1.5.ebuild
parentapp-arch/brotli: Switch back to cmake-utils.eclass (diff)
downloadgentoo-fd03bbd59bde96554286d52902bd6cd2209ca528.tar.gz
gentoo-fd03bbd59bde96554286d52902bd6cd2209ca528.tar.bz2
gentoo-fd03bbd59bde96554286d52902bd6cd2209ca528.zip
app-misc/hodie: new ebuild
A small program to display date differently. Closes: https://bugs.gentoo.org/188022 Closes: https://github.com/gentoo/gentoo/pull/13648 Signed-off-by: Peter Gantner <gentoo@nephros.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/hodie/hodie-1.5.ebuild')
-rw-r--r--app-misc/hodie/hodie-1.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/hodie/hodie-1.5.ebuild b/app-misc/hodie/hodie-1.5.ebuild
new file mode 100644
index 000000000000..93f8f86f99a4
--- /dev/null
+++ b/app-misc/hodie/hodie-1.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_COMMIT="5946cab2fab41c40b237a69e3aca08b1180cbc10"
+DESCRIPTION="a Latin date(1)"
+HOMEPAGE="http://hodie.sourceforge.net
+ https://github.com/michiexile/hodie"
+SRC_URI="https://github.com/michiexile/${PN}/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ doman hodie.1
+}