summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/countrycodes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/countrycodes')
-rw-r--r--app-misc/countrycodes/Manifest1
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild33
-rw-r--r--app-misc/countrycodes/files/1.0.5-Makefile.patch42
-rw-r--r--app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch12
-rw-r--r--app-misc/countrycodes/metadata.xml5
5 files changed, 93 insertions, 0 deletions
diff --git a/app-misc/countrycodes/Manifest b/app-misc/countrycodes/Manifest
new file mode 100644
index 000000000000..c6f2d65a9e54
--- /dev/null
+++ b/app-misc/countrycodes/Manifest
@@ -0,0 +1 @@
+DIST countrycodes-1.0.5.tar.gz 18621 SHA256 e56e10442c7353c39cd9e57fa747df279ae39a84a89336644a58c29de5b2b39b SHA512 d62beaaccdbc8f7e14f3edf0044aeeef6375a3deffc0e4246a49fb8209ed7256208c878f811950c5c3bfda729988a46c173aecec72ee66e8843932d97064f035 WHIRLPOOL e00e5d39080b25e8c599bf9c549dc24d9ee2393ffb52f5d9e98fcdf1479e4ac3599853e2e5f7893aaaaee7f0881e3a6cd0d9ab88e8157674b09c98adc33e7ae7
diff --git a/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild b/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..9c9e28715f4c
--- /dev/null
+++ b/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An ISO 3166 country code finder"
+HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
+SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+S="${WORKDIR}"/${P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+ tc-export CC
+}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man/man1" install || die "make install failed"
+ dosym iso3166 /usr/bin/countrycodes || die
+ dosym iso3166.1 /usr/share/man/man1/countrycodes || die
+ dodoc ../doc/{Changelog,README} || die
+ prepman
+}
diff --git a/app-misc/countrycodes/files/1.0.5-Makefile.patch b/app-misc/countrycodes/files/1.0.5-Makefile.patch
new file mode 100644
index 000000000000..4ee47e32dfd2
--- /dev/null
+++ b/app-misc/countrycodes/files/1.0.5-Makefile.patch
@@ -0,0 +1,42 @@
+diff --git a/src/Makefile b/src/Makefile
+index 9330578..3ff7319 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -26,13 +26,13 @@ BINMODE=755
+ LOGDIRMODE=700
+
+ # Compiler to use
+-CC=gcc
++CC ?= gcc
+
+ # Compiler warnings
+-WARNINGS= -pedantic -Wall
++WARNINGS=
+
+ # Compiler flags
+-CCOPTS = -O2 -fomit-frame-pointer
++CCOPTS = ${CFLAGS}
+
+ # The makefile standards document I read says that I have to put it here...
+ SHELL = /bin/sh
+@@ -61,7 +61,7 @@ PROGRAM = iso3166
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(ISO3166OBJ)
+- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
++ $(CC) $(CCOPTS) $(LDFLAGS) $(ISO3166OBJ) -o $@
+
+ clean:
+ rm -f $(ISO3166OBJ) core defines.h $(PROGRAM)
+@@ -70,8 +70,10 @@ strip:
+ strip $(PROGRAM)
+
+ install:
+- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
++ mkdir -p ${bindir}
++ $(INSTALL) -g root -m $(BINMODE) -o root ${srcdir}/$(PROGRAM) ${bindir}
+ @echo "Installing man page..."
++ mkdir -p ${mandir}
+ @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
+ @chown 0.0 ${mandir}/iso3166.1
+ @echo
diff --git a/app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch b/app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch
new file mode 100644
index 000000000000..619d7a072360
--- /dev/null
+++ b/app-misc/countrycodes/files/countrycodes-1.0.5-Makefile.patch
@@ -0,0 +1,12 @@
+diff -Naur countrycodes-1.0.5-orig/src/Makefile countrycodes-1.0.5/src/Makefile
+--- countrycodes-1.0.5-orig/src/Makefile 2003-02-01 09:56:08.000000000 -0600
++++ countrycodes-1.0.5/src/Makefile 2007-02-03 20:12:26.000000000 -0600
+@@ -70,7 +70,7 @@
+ strip $(PROGRAM)
+
+ install:
+- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
++ $(INSTALL) -g root -m $(BINMODE) -o root ${srcdir}/$(PROGRAM) ${bindir}
+ @echo "Installing man page..."
+ @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
+ @chown 0.0 ${mandir}/iso3166.1
diff --git a/app-misc/countrycodes/metadata.xml b/app-misc/countrycodes/metadata.xml
new file mode 100644
index 000000000000..40149c995561
--- /dev/null
+++ b/app-misc/countrycodes/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>