summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2023-02-26 22:27:47 +0900
committerAkinori Hattori <hattya@gentoo.org>2023-02-26 22:27:47 +0900
commitaeec64be5de65e8a58edc77cfbce2e4bb8a12b70 (patch)
tree02ae8cbed5966e50a0ce33b068930d9f3bbf823f /app-i18n
parentapp-i18n/ibus-m17n: new upstream release (diff)
downloadgentoo-aeec64be5de65e8a58edc77cfbce2e4bb8a12b70.tar.gz
gentoo-aeec64be5de65e8a58edc77cfbce2e4bb8a12b70.tar.bz2
gentoo-aeec64be5de65e8a58edc77cfbce2e4bb8a12b70.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.21.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 7869b5ad6be1..cc929dd7e106 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,3 +1,4 @@
DIST ibus-typing-booster-2.20.0.tar.gz 11175896 BLAKE2B 399b48617cd3d256e682b2d23d63c8931faecc4e83015d0be30040d516d3cd3a50e9366c460ebfe1f1ef2b2aa1363f4d2e2d2ac0ef9ad7016f6f2ecd6ee4f36b SHA512 8c7271d3029a28b045c9e9ffae9c9ac07adac3ac98749f30cd0959cfb91a50953372758c77c9820d713f2027d535d0752d1817281ce16be7e3594877b64177a5
DIST ibus-typing-booster-2.21.1.tar.gz 11182916 BLAKE2B a301173052cfa18a5b06ec5409550c5fcf9f76faa08a46567599a6c5f6481a346708366b808b29efeb33214b10001d49fc05859ec82d12e5cb23bd8e736b7546 SHA512 e0b643d8d24c97929889f8a5772651365c83e8c331a77e5510a317696caa22524f17ad4f7f31f202ae33b1a02d5ce3e8a209f2e9af5e9f41ce60a16fb038b1c7
DIST ibus-typing-booster-2.21.3.tar.gz 11219998 BLAKE2B 2d2f8a2664d280b05c74126ff132307c4b63c072fddfef63ffe7eb2de0d13a0a1530b7787459c7c7d4dba28ae77e5d277b628ec0c8c904806439e1ccf55c9c65 SHA512 a9a78b0b7d285982890eae30a562c642e9f746622119a968eebce3312d53211841c9e105942862e05548b1bfad1dbf1da033e341eb51f3fdde1c45a165d38649
+DIST ibus-typing-booster-2.21.4.tar.gz 11220794 BLAKE2B 7e5c7b9be31858ce1be7399b7dbada4cdec5a24f9d4f66d4e5ea110153d4696aa794650048b40dc52044ad90514f051a60234835d9b3c59aadb05aa6ba9eef4b SHA512 26dbc8cee8e6a6ec0414fc3e2f26298665030babed7f7dba7f52b5260b9aba511ab456fe49fb779f66b66b4db9fbe81faeec8692ad8a101e518d6fcf80189fd8
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.21.4.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.21.4.ebuild
new file mode 100644
index 000000000000..564f684f9809
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.21.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}