summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-04-19 22:10:57 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-04-19 22:10:57 +0900
commita73745ca6ba053ab6d3c052db27638ac1de5746c (patch)
tree1e407b5e1bb46c4677f9bdc8cba276ce953c5eaa /app-i18n
parentdev-lang/nim: wait longer for parallel (diff)
downloadgentoo-a73745ca6ba053ab6d3c052db27638ac1de5746c.tar.gz
gentoo-a73745ca6ba053ab6d3c052db27638ac1de5746c.tar.bz2
gentoo-a73745ca6ba053ab6d3c052db27638ac1de5746c.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index d6420ad723f9..5224b804f609 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,3 +1,4 @@
DIST ibus-typing-booster-2.25.3.tar.gz 12388617 BLAKE2B 44cbaa162ac76fb36f37117ebf0aa49b390dde89214ecac423e55a1a16b41df30ffd02039534e9873d54616ca68cca363c238429beb08cab1cc2955748a0b96c SHA512 df1ff9cd939c7fb72c616b239a5526060ab6840bae2c01c9e6ce338ac28cea0d4f525632f138e226b12ff6389574996fc523fe1722917db9f73d395927db9a4c
DIST ibus-typing-booster-2.25.4.tar.gz 12388721 BLAKE2B 3cce75d2524d2b1467d3feb7a0b2067309b88a6b070238f7e7524e426d9556e7624b15c3ff775280abb332ab899ef81fcdc0764e6a61e519947139a5aefc66b4 SHA512 f84111db28d84aa9888b2085ef1351e86c330479c65cf4ff64d87d36001093125c864460a3cb9084ecb430561556f2cf339ee0965a5025c8177a54fec67f4982
DIST ibus-typing-booster-2.25.6.tar.gz 12390887 BLAKE2B 5c0813e16829073e1066117fdf03c2fb713854572e5905f71cb98d51b1f172c8fbd7054fa38c08db7c1e82e1c779258b2934d95508db4914d9e15ade25f61b64 SHA512 212acfc9dcb9d9f3f4405dcfd5e35cf0fec48e41d74539a2a7f9a2b8eb2a1fa6b62919c12b7bbedb9f5ae4904fe463aee2c9801d59eec1389706489e485c54f9
+DIST ibus-typing-booster-2.25.7.tar.gz 12389694 BLAKE2B 192618e366b53849e94281ea4d9b98356f820ed6594dcd9ec1c4ddbfacf06d161fe44b4f37c19b3d007515c858b100a2f8b8fd6beb51088a668f269c86feadc6 SHA512 9603b99293e596c958aa2d21e8f0d78b06c6873769b2206c8f5bc225993d53e6af51d493d664d51b8632550e996f714a9ebf0c4ff8f914cd11b4119ac7570203
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.7.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.7.ebuild
new file mode 100644
index 000000000000..95f8e650235b
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}