summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-06-21 11:19:10 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-21 12:40:31 +0300
commit8dbbee583d5dbbcd9a0dbbcaa87800783a15e80a (patch)
treec1437ccb585412e0292f7962650d7f877c1fc2fb /app-i18n
parentsci-libs/gdal: bump 3.9.0 incl use parquet (diff)
downloadgentoo-8dbbee583d5dbbcd9a0dbbcaa87800783a15e80a.tar.gz
gentoo-8dbbee583d5dbbcd9a0dbbcaa87800783a15e80a.tar.bz2
gentoo-8dbbee583d5dbbcd9a0dbbcaa87800783a15e80a.zip
app-i18n/scim-sayura: EAPI 6 -> 8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-sayura/scim-sayura-0.3.3-r1.ebuild (renamed from app-i18n/scim-sayura/scim-sayura-0.3.3.ebuild)25
1 files changed, 17 insertions, 8 deletions
diff --git a/app-i18n/scim-sayura/scim-sayura-0.3.3.ebuild b/app-i18n/scim-sayura/scim-sayura-0.3.3-r1.ebuild
index f04f5993a8e9..b0c142039c51 100644
--- a/app-i18n/scim-sayura/scim-sayura-0.3.3.ebuild
+++ b/app-i18n/scim-sayura/scim-sayura-0.3.3-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit autotools
DESCRIPTION="Sayura Sinhala input method for SCIM"
HOMEPAGE="http://www.sayura.net/im/"
@@ -13,21 +15,28 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc"
RDEPEND=">=app-i18n/scim-0.99.8"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc45.patch
+)
-PATCHES=( "${FILESDIR}"/scim-sayura-0.3.3-gcc45.patch )
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
- econf --disable-static
+ econf
}
src_install() {
- HTML_DOCS=( doc/{index.html,style.css} )
+ local HTML_DOCS=( doc/{index.html,style.css} )
default
use doc && dodoc doc/sayura.pdf
# plugin module, no point in .la files
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -type f -name '*.la' -delete || die
}