summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-02-27 22:46:28 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-02-27 22:46:28 +0900
commit1a3440cb23a7dd46e52ded1110210ed201bf4974 (patch)
tree4f81b5c268a6178c97b9bf5bd28351b1e319fa0a /app-i18n
parentdev-tcltk/tkimg: update SRC_URI (diff)
downloadgentoo-1a3440cb23a7dd46e52ded1110210ed201bf4974.tar.gz
gentoo-1a3440cb23a7dd46e52ded1110210ed201bf4974.tar.bz2
gentoo-1a3440cb23a7dd46e52ded1110210ed201bf4974.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.3.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 69fdb69063e1..024c50cfa52e 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,3 +1,4 @@
DIST ibus-typing-booster-2.24.11.tar.gz 12321813 BLAKE2B 3757d6d43fb0837c10ad4641f72a3f09f2664e78905ebf98a36f723c07a43e1de85fd916a5c24aa13806d093a87d673f585234a36b4d8fc7cc8c8fc1a8d5d2d9 SHA512 9cc906061aaa8e4720e48296158c990b2411aad26f0ebf71e58bc202b2470d100541174e4e007c55e89c9b7540e21ef9107045dcff0e86ffba30cfd9acded989
DIST ibus-typing-booster-2.25.0.tar.gz 12346383 BLAKE2B 6bde5bebf641ae475634db8fc1d7f606905a593c8e6651a98af8147aa190d94e2db89e05c63da5d306f9188f7721d40059782f267efde0c5039551bf9d6fa1c3 SHA512 1559dcaa3f06c191993af84f317b7cf965f3f5539a43dffd86dfcca6f4bfe2fb1104d619bd7e4d1b83133c5e215bb993a65674555437b5311ee756fe70f4318e
DIST ibus-typing-booster-2.25.1.tar.gz 12351484 BLAKE2B 012c4300e186da54d6b1692cfd71669b49a38a85eaaf232ff934979835651fc6b75ea46016dd71d7f6d13d4cc63f94411808895b1aa762ca2ebc5a98bc3a4729 SHA512 98965fc11dca5b1ab52e18e19c4bd43d782cebc609524420e801421850cdb7235ebf9b28322829e23d845c689bb6501080653b429cf465018f8923c9b46dc231
+DIST ibus-typing-booster-2.25.3.tar.gz 12388617 BLAKE2B 44cbaa162ac76fb36f37117ebf0aa49b390dde89214ecac423e55a1a16b41df30ffd02039534e9873d54616ca68cca363c238429beb08cab1cc2955748a0b96c SHA512 df1ff9cd939c7fb72c616b239a5526060ab6840bae2c01c9e6ce338ac28cea0d4f525632f138e226b12ff6389574996fc523fe1722917db9f73d395927db9a4c
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.3.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.3.ebuild
new file mode 100644
index 000000000000..95f8e650235b
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.25.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}