summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2018-10-10 02:56:23 +0900
committerNaohiro Aota <naota@gentoo.org>2018-10-10 02:57:31 +0900
commit50be00f6ee1ce7eaa585389586a5d838e65e647b (patch)
tree2ed4aa43b6ffad6d0a821075ddc88574e2c51269 /app-i18n/opencc/files
parentdev-embedded/arduino-builder: version bump to 1.4.1 (diff)
downloadgentoo-50be00f6ee1ce7eaa585389586a5d838e65e647b.tar.gz
gentoo-50be00f6ee1ce7eaa585389586a5d838e65e647b.tar.bz2
gentoo-50be00f6ee1ce7eaa585389586a5d838e65e647b.zip
app-i18n/opencc: add patch to avoid conflicting copy
copy command is only necessary in VS build, and it's causing conflict on parallel build. Dropping the command is safe on Linux. Closes: https://bugs.gentoo.org/666904 Signed-off-by: Naohiro Aota <naota@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'app-i18n/opencc/files')
-rw-r--r--app-i18n/opencc/files/opencc-stop-copy.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/app-i18n/opencc/files/opencc-stop-copy.patch b/app-i18n/opencc/files/opencc-stop-copy.patch
new file mode 100644
index 000000000000..4793951dd251
--- /dev/null
+++ b/app-i18n/opencc/files/opencc-stop-copy.patch
@@ -0,0 +1,18 @@
+We don't need this copy command on Linux (or other than Visual Studio
+build). Since it is colliding each other on parallel build, drop the
+command for now.
+
+See https://bugs.gentoo.org/666904
+diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
+index 1516775..2deb764 100644
+--- a/data/CMakeLists.txt
++++ b/data/CMakeLists.txt
+@@ -109,8 +109,6 @@ foreach(DICT ${DICTS})
+ ${DICT}.ocd
+ COMMENT
+ "Building ${DICT}.ocd"
+- COMMAND
+- ${CMAKE_COMMAND} -E copy "$<TARGET_FILE:libopencc>" "$<TARGET_FILE_DIR:${OPENCC_DICT_BIN}>"
+ COMMAND
+ ${OPENCC_DICT_BIN}
+ --input ${DICT_${DICT}_INPUT}