summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-11-16 23:18:29 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-11-16 23:20:23 +0900
commit1f01637049291f36402c26a85e9ca5d3d527448a (patch)
tree0e83458d0e3cb064bd47137e2173149572d4c12a /app-i18n/ibus-typing-booster
parentapp-i18n/ibus-typing-booster: drop old (diff)
downloadgentoo-1f01637049291f36402c26a85e9ca5d3d527448a.tar.gz
gentoo-1f01637049291f36402c26a85e9ca5d3d527448a.tar.bz2
gentoo-1f01637049291f36402c26a85e9ca5d3d527448a.zip
app-i18n/ibus-typing-booster: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-i18n/ibus-typing-booster')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.26.11.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 36df92165e8a..c6cd9932e864 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1 +1,2 @@
DIST ibus-typing-booster-2.25.18.tar.gz 13294821 BLAKE2B ee88e528bd5707b910338a886a0dda54f38c6547936e423c848257efcaa2e5385eb854acee51870470f0dc0493ec96d885c9eb8a4cc660dda8cd5f8b62e9ed4e SHA512 57fb90658eaf55647ac4e501842e7ebe72aaf0dbe3979b64b141785827be5780f9cbd7ba52cf988c2845eac54fd898c4aa0a886517fcc3150edeb701708772ff
+DIST ibus-typing-booster-2.26.11.tar.gz 13334659 BLAKE2B 833bd3f86439369495105ab0013ee9e86b3505dce25b7effa763885137c1c14ee18c43d7d7cf6311c61729b19afe3943e9c64955b41f382a2cdcab00a2f1138b SHA512 1cd6f15831e7258bbb7cb02e59f2cc92d1e17cc9359a17a4b98a965c7bcc91d29ff562fc54007bbb67a331ad40123723852c65d16dc5944bfa6c480ac560641f
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.26.11.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.26.11.ebuild
new file mode 100644
index 000000000000..97351b6920ac
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.26.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}