summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-06 04:17:56 +0100
committerSam James <sam@gentoo.org>2022-07-06 04:18:32 +0100
commit7dde6a6bd36cadd1c70d8ec3d3f956750231eeff (patch)
tree5743e0bfe28707a38091941a2c63313121c213f8 /app-emulation
parentsys-libs/glibc: Re-keyword 2.35-r8 after testing (diff)
downloadgentoo-7dde6a6bd36cadd1c70d8ec3d3f956750231eeff.tar.gz
gentoo-7dde6a6bd36cadd1c70d8ec3d3f956750231eeff.tar.bz2
gentoo-7dde6a6bd36cadd1c70d8ec3d3f956750231eeff.zip
app-emulation/virtualbox: uncomment partial Python logic
Went back and forth on this but I think it's worth hinting as much as possible for now, given it's completely guessing otherwise, and we can't easily just rip out / disable Python entirely until we fix this. Bug: https://bugs.gentoo.org/856121 Bug: https://bugs.gentoo.org/785835 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virtualbox/virtualbox-6.1.34-r3.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/app-emulation/virtualbox/virtualbox-6.1.34-r3.ebuild b/app-emulation/virtualbox/virtualbox-6.1.34-r3.ebuild
index a352a9dd329b..1475e06f6fa0 100644
--- a/app-emulation/virtualbox/virtualbox-6.1.34-r3.ebuild
+++ b/app-emulation/virtualbox/virtualbox-6.1.34-r3.ebuild
@@ -280,20 +280,18 @@ src_configure() {
edo ./configure "${myconf[@]}"
# Try to force usage of chosen Python implementation
- # Commented out for now as it's insufficient (see comment above
- # PYTHON_COMPAT).
# bug #856121, bug #785835
- #sed -i \
- # -e '/VBOX_WITH_PYTHON.*=/d' \
- # -e '/VBOX_PATH_PYTHON_INC.*=/d' \
- # -e '/VBOX_LIB_PYTHON.*=/d' \
- # AutoConfig.kmk || die
- #
- #cat >> AutoConfig.kmk <<-EOF || die
- # VBOX_WITH_PYTHON=$(usex python 1 0)
- # VBOX_PATH_PYTHON_INC=$(python_get_includedir)
- # VBOX_LIB_PYTHON=$(python_get_library_path)
- #EOF
+ sed -i \
+ -e '/VBOX_WITH_PYTHON.*=/d' \
+ -e '/VBOX_PATH_PYTHON_INC.*=/d' \
+ -e '/VBOX_LIB_PYTHON.*=/d' \
+ AutoConfig.kmk || die
+
+ cat >> AutoConfig.kmk <<-EOF || die
+ VBOX_WITH_PYTHON=$(usex python 1 0)
+ VBOX_PATH_PYTHON_INC=$(python_get_includedir)
+ VBOX_LIB_PYTHON=$(python_get_library_path)
+ EOF
}
src_compile() {