summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2022-01-13 18:57:08 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2022-01-13 18:57:08 +0300
commit17ced59870ab1354c5f02920df5341625cc97f85 (patch)
treeb5904c2081ac8fbf924bf062b129c89117420001 /app-emulation
parentgnome-base/gnome-settings-daemon-41: fix minimum upower dep (diff)
downloadgentoo-17ced59870ab1354c5f02920df5341625cc97f85.tar.gz
gentoo-17ced59870ab1354c5f02920df5341625cc97f85.tar.bz2
gentoo-17ced59870ab1354c5f02920df5341625cc97f85.zip
app-emulation/glean: Version bump + QA fix
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/glean/Manifest1
-rw-r--r--app-emulation/glean/glean-1.18.2.ebuild4
-rw-r--r--app-emulation/glean/glean-1.19.0.ebuild26
3 files changed, 29 insertions, 2 deletions
diff --git a/app-emulation/glean/Manifest b/app-emulation/glean/Manifest
index db2a974a4e34..2216109b949f 100644
--- a/app-emulation/glean/Manifest
+++ b/app-emulation/glean/Manifest
@@ -1 +1,2 @@
DIST glean-1.18.2.tar.gz 67642 BLAKE2B b346fc63b361e7c7bf0b8fc100da4a047004950aff3e17fce96d47ae5a7887828a09f4b107f2af1afcf9d866e5bc0857049ddd2d9c49413e9fe4b61d1de99fd3 SHA512 de80c06952ebbbc24c8cf198f61be788fb32974652c8253787ed5a165e26bb162b48c84836779420bb7c331edeb50a7796f5a2ff578d2e612068c5fbadd343c7
+DIST glean-1.19.0.tar.gz 68806 BLAKE2B 14569fafe05ee0abd626c8302d54721d321b1c69bd0e72bb850c2fab7d7c49a0c5f27c20e4542e5c32a818d51f1fc29e8a14ff730ebbc4619399e710e6b9f9d4 SHA512 a4d063a921f6dac51d2e610121d359f289817cf57a52fadd6b8fd2c8c7f761433920c5d43b415edcaf3c4956bb67b3c19274aa6ec061b057a6bcb975d2662cd0
diff --git a/app-emulation/glean/glean-1.18.2.ebuild b/app-emulation/glean/glean-1.18.2.ebuild
index edd0b4838797..bd5b679fef7c 100644
--- a/app-emulation/glean/glean-1.18.2.ebuild
+++ b/app-emulation/glean/glean-1.18.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+PYTHON_COMPAT=( python3_{7,8,9,10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
diff --git a/app-emulation/glean/glean-1.19.0.ebuild b/app-emulation/glean/glean-1.19.0.ebuild
new file mode 100644
index 000000000000..2d07441e5a1c
--- /dev/null
+++ b/app-emulation/glean/glean-1.19.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9,10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Simple program to write static config from config-drive"
+HOMEPAGE="https://opendev.org/opendev/glean"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}