summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-25 13:03:53 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-25 13:04:16 +0100
commit1eff352f571c93e2fa4d0716bb9b51318964ff1c (patch)
treeb24e0147be4c2cbe415c68f29f8159c679bc4230 /app-emulation/virtualbox-modules
parentnet-analyzer/zabbix: Bump (diff)
downloadgentoo-1eff352f571c93e2fa4d0716bb9b51318964ff1c.tar.gz
gentoo-1eff352f571c93e2fa4d0716bb9b51318964ff1c.tar.bz2
gentoo-1eff352f571c93e2fa4d0716bb9b51318964ff1c.zip
virtualbox packages: Security cleanup.
Bug: https://bugs.gentoo.org/644894 Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'app-emulation/virtualbox-modules')
-rw-r--r--app-emulation/virtualbox-modules/Manifest2
-rw-r--r--app-emulation/virtualbox-modules/virtualbox-modules-5.1.30.ebuild68
-rw-r--r--app-emulation/virtualbox-modules/virtualbox-modules-5.2.4.ebuild59
3 files changed, 0 insertions, 129 deletions
diff --git a/app-emulation/virtualbox-modules/Manifest b/app-emulation/virtualbox-modules/Manifest
index 843be050f206..51e286048f7a 100644
--- a/app-emulation/virtualbox-modules/Manifest
+++ b/app-emulation/virtualbox-modules/Manifest
@@ -1,4 +1,2 @@
-DIST vbox-kernel-module-src-5.1.30.tar.xz 625424 BLAKE2B 00d33cad237af1f0d5b4dbea38f84e0327d10d97fc309a8c7536433cb4fddf3614e6de160646077040b4fdc6dd126cfa2250081084ca0243cc572d9f5e9d5dfd SHA512 8e2113584e63e2ace71b708dc77428fd09167a1bded12b47312a5a8f85ef448e17f76b4300dba4c8ec99d7f8cb278cef039c6282c676e35b8f200bafb5c4770a
DIST vbox-kernel-module-src-5.1.32.tar.xz 626600 BLAKE2B eb3243d62d1a22f41f5ea2307b13a3f5ce17a19edcecb0340f94d34995e557b016195443a53edc9d68a313d064008e5af04c7fff28540ec513c6e9a5955e02e0 SHA512 10ead68e53ae6bd72e39b31d536fc36e0999fe506a6d7fd6a6f9e462d539213ad65deb56e2b926baa5cc4b16fb4071d89e105889e873fda0e4a1f20387a7cd39
-DIST vbox-kernel-module-src-5.2.4.tar.xz 634212 BLAKE2B d8be416f958f672c2ab50b5197f708bc1febca292d5262eec710c07561be7de810fb1dfd5961ef9367c91e0ac1b6033419f85444471e8d40406d4ab860de2a23 SHA512 3c2113a8781cde1a44954267ee469db91c843305a5b1468b1fd346af3f3626a3d98c8a958ec0e255401f569f75e652dbbb1a85fd6cc6b203cf170745c630cee1
DIST vbox-kernel-module-src-5.2.6.tar.xz 635096 BLAKE2B 8c168b9e1d3de395ef663ca81edf63939cb7670f769995c20f9d4cb4f87194b22812707bfd62d52dd85e19de2562c27c182aad22f40928358cf07a0c5ac15d79 SHA512 c85f94e08357a11574af306b00e71c445b80ef6dea6c47d9cf1003c0d9f36d265ebadd2ae27b3dd96f41cc544e501d3eb0551559bebf25d35b9861a282f489bc
diff --git a/app-emulation/virtualbox-modules/virtualbox-modules-5.1.30.ebuild b/app-emulation/virtualbox-modules/virtualbox-modules-5.1.30.ebuild
deleted file mode 100644
index 14b649c9c34f..000000000000
--- a/app-emulation/virtualbox-modules/virtualbox-modules-5.1.30.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# XXX: the tarball here is just the kernel modules split out of the binary
-# package that comes from virtualbox-bin
-
-EAPI=6
-
-inherit eutils linux-mod user
-
-MY_P=vbox-kernel-module-src-${PV}
-DESCRIPTION="Kernel Modules for Virtualbox"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="https://dev.gentoo.org/~polynomial-c/virtualbox/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="pax_kernel"
-
-RDEPEND="!=app-emulation/virtualbox-9999"
-
-S=${WORKDIR}
-
-BUILD_TARGETS="all"
-BUILD_TARGET_ARCH="${ARCH}"
-MODULE_NAMES="vboxdrv(misc:${S}) vboxnetflt(misc:${S}) vboxnetadp(misc:${S}) vboxpci(misc:${S})"
-
-pkg_setup() {
- enewgroup vboxusers
-
- CONFIG_CHECK="!TRIM_UNUSED_KSYMS"
- ERROR_TRIM_UNUSED_KSYMS="The kernel option CONFIG_TRIM_UNUSED_KSYMS removed kernel symbols that are needed by ${PN} to load correctly."
-
- linux-mod_pkg_setup
-
- BUILD_PARAMS="KERN_DIR=${KV_DIR} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1"
-}
-
-src_prepare() {
- if kernel_is -ge 2 6 33 ; then
- # evil patch for new kernels - header moved
- grep -lR linux/autoconf.h * | xargs sed -i -e 's:<linux/autoconf.h>:<generated/autoconf.h>:'
- fi
-
- if use pax_kernel && kernel_is -ge 3 0 0 ; then
- epatch "${FILESDIR}"/${PN}-4.1.4-pax-const.patch
- fi
-
- if kernel_is -ge 4 14 0 ; then
- epatch "${FILESDIR}"/${PN}-5.1.30-udp.patch
- fi
-
- default
-}
-
-src_install() {
- linux-mod_src_install
- insinto /usr/lib/modules-load.d/
- doins "${FILESDIR}"/virtualbox.conf
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- elog "If you are using sys-apps/openrc, please add \"vboxdrv\", \"vboxnetflt\","
- elog "\"vboxnetadp\" and \"vboxpci\" to:"
- elog " /etc/conf.d/modules"
-}
diff --git a/app-emulation/virtualbox-modules/virtualbox-modules-5.2.4.ebuild b/app-emulation/virtualbox-modules/virtualbox-modules-5.2.4.ebuild
deleted file mode 100644
index 2c9761e6f22f..000000000000
--- a/app-emulation/virtualbox-modules/virtualbox-modules-5.2.4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# XXX: the tarball here is just the kernel modules split out of the binary
-# package that comes from virtualbox-bin
-
-EAPI=6
-
-inherit eutils linux-mod user
-
-MY_P=vbox-kernel-module-src-${PV}
-DESCRIPTION="Kernel Modules for Virtualbox"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="https://dev.gentoo.org/~polynomial-c/virtualbox/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="pax_kernel"
-
-RDEPEND="!=app-emulation/virtualbox-9999"
-
-S=${WORKDIR}
-
-BUILD_TARGETS="all"
-BUILD_TARGET_ARCH="${ARCH}"
-MODULE_NAMES="vboxdrv(misc:${S}) vboxnetflt(misc:${S}) vboxnetadp(misc:${S}) vboxpci(misc:${S})"
-
-pkg_setup() {
- enewgroup vboxusers
-
- CONFIG_CHECK="!TRIM_UNUSED_KSYMS"
- ERROR_TRIM_UNUSED_KSYMS="The kernel option CONFIG_TRIM_UNUSED_KSYMS removed kernel symbols that are needed by ${PN} to load correctly."
-
- linux-mod_pkg_setup
-
- BUILD_PARAMS="KERN_DIR=${KV_DIR} KERN_VER=${KV_FULL} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1"
-}
-
-src_prepare() {
- if use pax_kernel && kernel_is -ge 3 0 0 ; then
- epatch "${FILESDIR}"/${PN}-4.1.4-pax-const.patch
- fi
-
- default
-}
-
-src_install() {
- linux-mod_src_install
- insinto /usr/lib/modules-load.d/
- doins "${FILESDIR}"/virtualbox.conf
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- elog "If you are using sys-apps/openrc, please add \"vboxdrv\", \"vboxnetflt\","
- elog "\"vboxnetadp\" and \"vboxpci\" to:"
- elog " /etc/conf.d/modules"
-}