summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-12-05 20:55:15 -0500
committerNick Sarnie <sarnex@gentoo.org>2022-12-05 20:58:51 -0500
commite9e5a76e9db897b85f87d705f30040858ccb66e4 (patch)
tree95cd9eb2338f8b920c28e1c6b33993e7ae0917d8 /app-emulation/vendor-reset
parentwww-apps/icingaweb2: stabilize 2.11.2 for amd64, x86 (diff)
downloadgentoo-e9e5a76e9db897b85f87d705f30040858ccb66e4.tar.gz
gentoo-e9e5a76e9db897b85f87d705f30040858ccb66e4.tar.bz2
gentoo-e9e5a76e9db897b85f87d705f30040858ccb66e4.zip
app-emulation/vendor-reset: Version bump, bugfix
Closes: https://bugs.gentoo.org/778890 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/vendor-reset')
-rw-r--r--app-emulation/vendor-reset/Manifest2
-rw-r--r--app-emulation/vendor-reset/files/Respect-eselect-kernel.patch13
-rw-r--r--app-emulation/vendor-reset/vendor-reset-0.1.1_pre20221205.ebuild (renamed from app-emulation/vendor-reset/vendor-reset-0.1.1_pre20220902.ebuild)6
-rw-r--r--app-emulation/vendor-reset/vendor-reset-9999.ebuild7
4 files changed, 25 insertions, 3 deletions
diff --git a/app-emulation/vendor-reset/Manifest b/app-emulation/vendor-reset/Manifest
index 17660f5bb12e..6ddfbd7eb277 100644
--- a/app-emulation/vendor-reset/Manifest
+++ b/app-emulation/vendor-reset/Manifest
@@ -1,2 +1,2 @@
DIST vendor-reset-0.1.0.tar.gz 12718324 BLAKE2B 762ec8bc289b572ab8f8ecc3fa233e3c78c48c48a261c58ce1be9c10356a55957e0bd8fd01e3143443be74236bf9ed540b84d332788c67aa949599ccc5a564d3 SHA512 ed4dcb1a71fa8901732e729d37b501ac105cc2c93d0666e44c08e311d99a244027339d5709a9305ff992ca2acb2f337793cdb1f9369197911985cd20d6f3139f
-DIST vendor-reset-0.1.1_pre20220902.tar.gz 12724563 BLAKE2B 6d1aa45216a4a72981fc766ba7541873902272a27b5eebc08f7b2627f186d6236c3b6f576f997e35a3a9a3bb4b0c5f6a285585522e7c0eb86b446808e2de501b SHA512 27bc02fdbc7d0339c0f706e1ec8406bc47f163fca6d6471dd7ad92272a384ab7319f6180641177f90a38c11aee2def52ae408a2165438980b7fc3aea10f88b4e
+DIST vendor-reset-0.1.1_pre20221205.tar.gz 12725340 BLAKE2B 5f2e34b74e83c8f48daad8d2c714872ab23f50cb0fad6b5c7920476b43c2fbfcf5543e923c506dfb2d8c33846e8fdd08c7d20b30fcc053f2c191d813872b44c5 SHA512 87a3c64d917e6a44308115480f14956f65a9f84fef70de29feebe3fcd7d522b59a3dbcb5fc9a340ac9b7a3612a29ed696b4f52648f86a0d877b915c97c5a4cc9
diff --git a/app-emulation/vendor-reset/files/Respect-eselect-kernel.patch b/app-emulation/vendor-reset/files/Respect-eselect-kernel.patch
new file mode 100644
index 000000000000..9259a3e12bf2
--- /dev/null
+++ b/app-emulation/vendor-reset/files/Respect-eselect-kernel.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index b8a0652..79f60e8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ USER := $(shell whoami)
+-KVER ?= $(shell uname -r)
+-KDIR ?= /lib/modules/$(KVER)/build
++KVER ?= $(KV_FULL)
++KDIR ?= ${KERNEL_DIR}
+
+ all: build
+
diff --git a/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20220902.ebuild b/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20221205.ebuild
index d0f34c496d9c..ceaaa99a4a5f 100644
--- a/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20220902.ebuild
+++ b/app-emulation/vendor-reset/vendor-reset-0.1.1_pre20221205.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
KEYWORDS="~amd64"
- EGIT_COMMIT="7d43285a5054e4b2b18dbba771b57d365943a0f7"
+ EGIT_COMMIT="4b466e92a2d9f76ce1082cde982c7be0be91e248"
SRC_URI="https://github.com/gnif/vendor-reset/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
fi
@@ -24,9 +24,13 @@ DEPEND=""
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+PATCHES=( "${FILESDIR}/Respect-eselect-kernel.patch" )
+
pkg_setup() {
local CONFIG_CHECK="FTRACE KPROBES PCI_QUIRKS KALLSYMS FUNCTION_TRACER"
linux-mod_pkg_setup
+ export KV_FULL=${KV_FULL}
+ export KERNEL_DIR=${KERNEL_DIR}
}
src_compile() {
diff --git a/app-emulation/vendor-reset/vendor-reset-9999.ebuild b/app-emulation/vendor-reset/vendor-reset-9999.ebuild
index 64f307942f3d..a0b2326fc95a 100644
--- a/app-emulation/vendor-reset/vendor-reset-9999.ebuild
+++ b/app-emulation/vendor-reset/vendor-reset-9999.ebuild
@@ -11,7 +11,8 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
KEYWORDS="~amd64"
- SRC_URI="https://github.com/gnif/vendor-reset/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ EGIT_COMMIT="4b466e92a2d9f76ce1082cde982c7be0be91e248"
+ SRC_URI="https://github.com/gnif/vendor-reset/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
fi
DESCRIPTION="Linux kernel vendor specific hardware reset module"
@@ -22,9 +23,13 @@ SLOT="0"
DEPEND=""
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/Respect-eselect-kernel.patch" )
+
pkg_setup() {
local CONFIG_CHECK="FTRACE KPROBES PCI_QUIRKS KALLSYMS FUNCTION_TRACER"
linux-mod_pkg_setup
+ export KV_FULL=${KV_FULL}
+ export KERNEL_DIR=${KERNEL_DIR}
}
src_compile() {