summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-15 04:52:10 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-15 04:53:00 -0500
commit7c0d73c23a9021b5cca177ddf09f2bcd9165ef44 (patch)
treef64fafdddf33422352e6035104e68f078d0e253c /app-emulation/ruffle
parentkde-plasma/libksysguard: Fix segfault in process list tree view mode (diff)
downloadgentoo-7c0d73c23a9021b5cca177ddf09f2bcd9165ef44.tar.gz
gentoo-7c0d73c23a9021b5cca177ddf09f2bcd9165ef44.tar.bz2
gentoo-7c0d73c23a9021b5cca177ddf09f2bcd9165ef44.zip
app-emulation/ruffle: set PYTHON_REQ_USE=xml
Closes: https://bugs.gentoo.org/829233 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/ruffle')
-rw-r--r--app-emulation/ruffle/ruffle-0_p20211214.ebuild1
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/app-emulation/ruffle/ruffle-0_p20211214.ebuild b/app-emulation/ruffle/ruffle-0_p20211214.ebuild
index fd3e952ec3bb..f55ac59a9cc7 100644
--- a/app-emulation/ruffle/ruffle-0_p20211214.ebuild
+++ b/app-emulation/ruffle/ruffle-0_p20211214.ebuild
@@ -388,6 +388,7 @@ CRATES="
xml-rs-0.8.4"
# python is needed by xcb-0.8.2 until update to >=0.10
PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml"
inherit cargo desktop flag-o-matic python-any-r1 xdg
# 0(github) 1(repo) 2(commit hash) 3(crate:workspace,...) [see core/Cargo.toml]
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index 085d64c07400..4371c33e066a 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -5,6 +5,7 @@ EAPI=8
# python is needed by xcb-0.8.2 until update to >=0.10
PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml"
inherit cargo desktop flag-o-matic git-r3 python-any-r1 xdg
DESCRIPTION="Flash Player emulator written in Rust"