summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-08-27 22:31:42 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-08-27 22:32:29 +0100
commit07e7677694e74d5410824fa70febbff79d77d5bf (patch)
tree7e09ab4d8e70b2656eafc255a1894ca563180c42 /app-emulation/fs-uae
parentmedia-plugins/gst-plugins-vaapi: bump to 1.14.5 for upstream bug fixes (diff)
downloadgentoo-07e7677694e74d5410824fa70febbff79d77d5bf.tar.gz
gentoo-07e7677694e74d5410824fa70febbff79d77d5bf.tar.bz2
gentoo-07e7677694e74d5410824fa70febbff79d77d5bf.zip
app-emulation/fs-uae: Fix missing X11/Xatom.h include
I think this was breaking when SDL2 was built with USE=-X. I think it needs USE=X but I have added the missing include anyway and sent the patch upstream. Closes: https://bugs.gentoo.org/689994 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-emulation/fs-uae')
-rw-r--r--app-emulation/fs-uae/files/fs-uae-3.0.0-Xatom.h.patch25
-rw-r--r--app-emulation/fs-uae/fs-uae-3.0.0.ebuild3
2 files changed, 27 insertions, 1 deletions
diff --git a/app-emulation/fs-uae/files/fs-uae-3.0.0-Xatom.h.patch b/app-emulation/fs-uae/files/fs-uae-3.0.0-Xatom.h.patch
new file mode 100644
index 000000000000..8fa5bd612c43
--- /dev/null
+++ b/app-emulation/fs-uae/files/fs-uae-3.0.0-Xatom.h.patch
@@ -0,0 +1,25 @@
+From c4c267a90d412bc6d072615d38ce891325282b6d Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Tue, 27 Aug 2019 22:22:57 +0100
+Subject: [PATCH] Add missing X11/Xatom.h include
+
+It is sometimes (but not always?) included by SDL2.
+---
+ libfsemu/src/ml/x11.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/libfsemu/src/ml/x11.c b/libfsemu/src/ml/x11.c
+index c20073d3..4dc5487c 100644
+--- a/libfsemu/src/ml/x11.c
++++ b/libfsemu/src/ml/x11.c
+@@ -26,6 +26,7 @@ extern SDL_Window* g_fs_ml_window;
+
+ #include <X11/Xlib.h>
+ #include <X11/keysym.h>
++#include <X11/Xatom.h>
+ #ifdef USE_X11_XTEST
+ #include <X11/extensions/XTest.h>
+ #endif
+--
+2.21.0
+
diff --git a/app-emulation/fs-uae/fs-uae-3.0.0.ebuild b/app-emulation/fs-uae/fs-uae-3.0.0.ebuild
index 376c782ca59f..f0492ee2c5ae 100644
--- a/app-emulation/fs-uae/fs-uae-3.0.0.ebuild
+++ b/app-emulation/fs-uae/fs-uae-3.0.0.ebuild
@@ -16,7 +16,7 @@ IUSE="fmv glew"
RDEPEND="
dev-libs/glib:2
media-libs/libpng:0=
- media-libs/libsdl2[opengl]
+ media-libs/libsdl2[opengl,X]
media-libs/openal
virtual/opengl
x11-libs/libdrm
@@ -37,6 +37,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-3.0.0-libmpeg2.patch
+ "${FILESDIR}"/${PN}-3.0.0-Xatom.h.patch
)
src_prepare() {