summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrett Holman <bholman.devel@gmail.com>2022-04-10 12:01:29 -0600
committerSam James <sam@gentoo.org>2022-04-12 02:07:31 +0100
commitc8e61d9aeb9e101fbb37aee80cabe613ae036373 (patch)
treea02c3d480856d28e5d4ad2b8e401c245174f2274 /app-emulation/cloud-init
parentmedia-tv/mythtv: fix typo (diff)
downloadgentoo-c8e61d9aeb9e101fbb37aee80cabe613ae036373.tar.gz
gentoo-c8e61d9aeb9e101fbb37aee80cabe613ae036373.tar.bz2
gentoo-c8e61d9aeb9e101fbb37aee80cabe613ae036373.zip
app-emulation/cloud-init: Backport package dep fixes
These were changed in upstream commits: 4d2684848722cb2d469ad4fa60999bf81cf7056e - May 2, 2020 - six removed 986f37b017134ced5d9dd38b420350916297002b - Mar 10, 2020 - nose -> pytest 8b4a9bc7b81e61943af873bad92e2133f8275b0b - Aug 9, 2021 - netifaces added Closes: https://github.com/gentoo/gentoo/pull/24980 Signed-off-by: Brett Holman <bholman.devel@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/cloud-init')
-rw-r--r--app-emulation/cloud-init/cloud-init-20.4.ebuild7
-rw-r--r--app-emulation/cloud-init/cloud-init-21.2.ebuild7
-rw-r--r--app-emulation/cloud-init/cloud-init-22.1.ebuild5
3 files changed, 8 insertions, 11 deletions
diff --git a/app-emulation/cloud-init/cloud-init-20.4.ebuild b/app-emulation/cloud-init/cloud-init-20.4.ebuild
index 89910008a34f..63d26e689413 100644
--- a/app-emulation/cloud-init/cloud-init-20.4.ebuild
+++ b/app-emulation/cloud-init/cloud-init-20.4.ebuild
@@ -32,14 +32,13 @@ CDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/jsonpatch[${PYTHON_USEDEP}]
dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="
test? (
${CDEPEND}
>=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
)
"
@@ -69,8 +68,8 @@ python_prepare_all() {
}
python_test() {
- # Do not use Makefile target as it does not setup environment correclty
- esetup.py nosetests -v --where cloudinit --where tests/unittests || die
+ # Do not use Makefile target as it does not setup environment correctly
+ esetup.py pytest -v cloudinit/ tests/unittests || die
}
python_install() {
diff --git a/app-emulation/cloud-init/cloud-init-21.2.ebuild b/app-emulation/cloud-init/cloud-init-21.2.ebuild
index 55f12c07641e..0a9661be7209 100644
--- a/app-emulation/cloud-init/cloud-init-21.2.ebuild
+++ b/app-emulation/cloud-init/cloud-init-21.2.ebuild
@@ -32,14 +32,13 @@ CDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/jsonpatch[${PYTHON_USEDEP}]
dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="
${CDEPEND}
test? (
>=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
)
"
@@ -69,8 +68,8 @@ python_prepare_all() {
}
python_test() {
- # Do not use Makefile target as it does not setup environment correclty
- esetup.py nosetests -v --where cloudinit --where tests/unittests || die
+ # Do not use Makefile target as it does not setup environment correctly
+ esetup.py pytest -v cloudinit tests/unittests || die
}
python_install() {
diff --git a/app-emulation/cloud-init/cloud-init-22.1.ebuild b/app-emulation/cloud-init/cloud-init-22.1.ebuild
index ace04bcfa721..fcd8771ebb89 100644
--- a/app-emulation/cloud-init/cloud-init-22.1.ebuild
+++ b/app-emulation/cloud-init/cloud-init-22.1.ebuild
@@ -33,14 +33,13 @@ CDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/jsonpatch[${PYTHON_USEDEP}]
dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netifaces[${PYTHON_USEDEP}]
"
DEPEND="
${CDEPEND}
test? (
>=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
)
"
@@ -59,7 +58,7 @@ PATCHES=(
"${FILESDIR}"/22.1-add-support-for-package_upgrade.patch
)
-distutils_enable_tests nose
+distutils_enable_tests pytest
python_prepare_all() {
# Fix location of documentation installation