summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-02-17 19:31:54 +0000
committerMatthew Smith <matthew@gentoo.org>2022-02-17 19:43:50 +0000
commit230c029707ce72c5d7185325ab90ac943c9288f7 (patch)
tree32012a03922afb46394a2ce46dec095fe260d06e /app-emacs
parentapp-emacs/orderless: initial import at 0.7 (diff)
downloadgentoo-230c029707ce72c5d7185325ab90ac943c9288f7.tar.gz
gentoo-230c029707ce72c5d7185325ab90ac943c9288f7.tar.bz2
gentoo-230c029707ce72c5d7185325ab90ac943c9288f7.zip
app-emacs/vertico: initial import at 0.20
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/vertico/Manifest1
-rw-r--r--app-emacs/vertico/files/50vertico-gentoo.el2
-rw-r--r--app-emacs/vertico/metadata.xml12
-rw-r--r--app-emacs/vertico/vertico-0.20.ebuild27
4 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/vertico/Manifest b/app-emacs/vertico/Manifest
new file mode 100644
index 000000000000..2ba3717a0e58
--- /dev/null
+++ b/app-emacs/vertico/Manifest
@@ -0,0 +1 @@
+DIST vertico-0.20.tar.gz 40899 BLAKE2B 73f42eefc43095c58c38570fac2fc915f7a1d7095f2b1864834eb57d658114ee3a4a98fb834c64793810505e171602801d8a492eecc7349137833442fc02b715 SHA512 0e683a572fec4ba223f03672461b4888667e35202dd1b2efc139127d3327d6d7a6d7eab96549239e6dad6e86054854b49a3be553ce482fd2e683bdb029e3a9c0
diff --git a/app-emacs/vertico/files/50vertico-gentoo.el b/app-emacs/vertico/files/50vertico-gentoo.el
new file mode 100644
index 000000000000..a7d1b3665969
--- /dev/null
+++ b/app-emacs/vertico/files/50vertico-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/vertico-autoloads" nil t)
diff --git a/app-emacs/vertico/metadata.xml b/app-emacs/vertico/metadata.xml
new file mode 100644
index 000000000000..f5159c9e8ada
--- /dev/null
+++ b/app-emacs/vertico/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">minad/vertico</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/vertico/vertico-0.20.ebuild b/app-emacs/vertico/vertico-0.20.ebuild
new file mode 100644
index 000000000000..d2415e174e28
--- /dev/null
+++ b/app-emacs/vertico/vertico-0.20.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico"
+SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}