summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-11-26 14:33:24 +0000
committerMatthew Smith <matthew@gentoo.org>2022-11-26 14:33:24 +0000
commit155584fd6786177de7312adefcd86bfeaf274d1b (patch)
treed145b019832f358e89b82897528da1d2f3a5b338 /app-emacs
parentdev-vcs/git-delete-merged-branches: 7.2.1 (diff)
downloadgentoo-155584fd6786177de7312adefcd86bfeaf274d1b.tar.gz
gentoo-155584fd6786177de7312adefcd86bfeaf274d1b.tar.bz2
gentoo-155584fd6786177de7312adefcd86bfeaf274d1b.zip
app-emacs/paredit: add 25
Also change HOMEPAGE to new website, and enable tests. Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/paredit/Manifest1
-rw-r--r--app-emacs/paredit/paredit-25.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/app-emacs/paredit/Manifest b/app-emacs/paredit/Manifest
index 504ade03cf7c..d2059fdca23e 100644
--- a/app-emacs/paredit/Manifest
+++ b/app-emacs/paredit/Manifest
@@ -1,2 +1,3 @@
DIST paredit-23.html.xz 1920 BLAKE2B 029c09848bb162c135c882ca17e6d5da9c3c17ba3937a809dcd03edb4b1841a0069a72dbd6676003cdf1a9de60a1f88eefa1de050210a37b52a005d28892ab14 SHA512 0ef584787b6094f1d0720aeb4d3a8c106605be62ffaa240d27a190ed9a6dd83d6d1ce68c2d184e84539a0e0658dcbed068335b69f4b1905ae9bf3d9968d5fb9b
DIST paredit-24.el.xz 24332 BLAKE2B 5243810cfcc40ebfd62ce3f833afa214defe9b91affbeb142ddad308e1fcff3f54a0ed19029a5ebd31f374868abc34f160d2efac65a609e783483ba2c92194d2 SHA512 76d9d2694473aeaab573964d79418fba20bfecef7f3771682f769ef05fb9385f9ef6dda1a5c7edec5d0a6f919d2eca5e75d595bd8cd5220c5179bfcac5f20f94
+DIST paredit-25.tar.xz 33552 BLAKE2B 7fd36e796c754a6bca28d3bbdf59c37bba326870a6ba94380b4c6130a5f0be103ef8ced0071059faa785fbad7cdcfecd0eb491a2b07200cc6e3208b61b0a2af2 SHA512 46ae5eee7007d7ddc2c03955f521dac950b88ee3274faf071983380d83b30b553da7d21fbe791a2c760f0f56b7fd177714085c18a8dbc5c50bc0a240bf7e77aa
diff --git a/app-emacs/paredit/paredit-25.ebuild b/app-emacs/paredit/paredit-25.ebuild
new file mode 100644
index 000000000000..8510221c5950
--- /dev/null
+++ b/app-emacs/paredit/paredit-25.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Minor mode for performing structured editing of S-expressions"
+HOMEPAGE="https://paredit.org https://www.emacswiki.org/emacs/ParEdit"
+SRC_URI="https://dev.gentoo.org/~matthew/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( ${PN}.html )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -l ${PN}.el -l test.el || die 'tests failed'
+}