summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-20 22:41:30 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-20 22:41:30 +0900
commitd91658c607b4d4147e5c75c65b7f1baed5dd8776 (patch)
tree834bf705f51a6c15740f647d095e08a6b206fcdb /app-emacs/yc
parentx11-wm/lumina: Renamed 1.2.0-r1 ebuild to 1.2.0_p1 (diff)
downloadgentoo-d91658c607b4d4147e5c75c65b7f1baed5dd8776.tar.gz
gentoo-d91658c607b4d4147e5c75c65b7f1baed5dd8776.tar.bz2
gentoo-d91658c607b4d4147e5c75c65b7f1baed5dd8776.zip
app-emacs/yc: update to EAPI 6
Gentoo-Bug: 621518 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-emacs/yc')
-rw-r--r--app-emacs/yc/files/50yc-gentoo.el3
-rw-r--r--app-emacs/yc/files/sample.dot.emacs (renamed from app-emacs/yc/files/sample.dot.emacs-4)0
-rw-r--r--app-emacs/yc/metadata.xml16
-rw-r--r--app-emacs/yc/yc-4.0.13.ebuild48
4 files changed, 31 insertions, 36 deletions
diff --git a/app-emacs/yc/files/50yc-gentoo.el b/app-emacs/yc/files/50yc-gentoo.el
index 33bd4a72a454..431f7e90ae73 100644
--- a/app-emacs/yc/files/50yc-gentoo.el
+++ b/app-emacs/yc/files/50yc-gentoo.el
@@ -1,4 +1 @@
-
-;;; YC site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/yc/files/sample.dot.emacs-4 b/app-emacs/yc/files/sample.dot.emacs
index 101532e704a6..101532e704a6 100644
--- a/app-emacs/yc/files/sample.dot.emacs-4
+++ b/app-emacs/yc/files/sample.dot.emacs
diff --git a/app-emacs/yc/metadata.xml b/app-emacs/yc/metadata.xml
index 02fb2539160f..2c9ca3c416d2 100644
--- a/app-emacs/yc/metadata.xml
+++ b/app-emacs/yc/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>gnu-emacs@gentoo.org</email>
- <name>Gentoo GNU Emacs project</name>
-</maintainer>
-<maintainer type="project">
- <email>cjk@gentoo.org</email>
- <name>Cjk</name>
-</maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
</pkgmetadata>
diff --git a/app-emacs/yc/yc-4.0.13.ebuild b/app-emacs/yc/yc-4.0.13.ebuild
index f2724d973965..a8179e6426bb 100644
--- a/app-emacs/yc/yc-4.0.13.ebuild
+++ b/app-emacs/yc/yc-4.0.13.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI="6"
inherit elisp toolchain-funcs
@@ -14,42 +14,40 @@ SLOT="0"
KEYWORDS="alpha ~amd64 ppc x86"
IUSE=""
-DEPEND=""
-RDEPEND=">=app-i18n/canna-3.6"
+RDEPEND="app-i18n/canna"
SITEFILE="50${PN}-gentoo.el"
src_prepare() {
- sed -e 's:$(CC) -o $(PROGRAM) $(OBJS):$(CC) ${CFLAGS} ${LDFLAGS} -o $(PROGRAM) $(OBJS):' -i Makefile || die
+ sed -i '/$(CC)/s/ -o / $(CFLAGS) $(LDFLAGS) -o /' Makefile
+
+ default
}
src_compile() {
- emake CC="$(tc-getCC)" || die
+ emake CC="$(tc-getCC)"
}
src_install() {
- elisp-install ${PN} *.el *.elc || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- dobin icanna || die
- newdoc "${FILESDIR}"/sample.dot.emacs-4 sample.dot.emacs || die
- dodoc "${FILESDIR}"/sample.hosts.canna || die
+ elisp_src_install
+
+ dobin icanna
+ dodoc "${FILESDIR}"/sample.{dot.emacs,hosts.canna}
}
pkg_postinst() {
- elisp-site-regen
- elog "See the sample.dot.emacs file in /usr/share/doc/${PF}/."
+ elisp_pkg_postinst
+
+ elog "See the sample.dot.emacs in ${EPREFIX}/usr/share/doc/${PF}."
elog
- elog "And If you use unix domain socket for connecting the canna server, "
- elog " please confirm that there's *no* following line in your .emacs ."
- elog " (setq yc-server-host \"localhost\")"
+ elog "And If you use unix domain socket for connecting the canna server,"
+ elog "please confirm that there's *no* following line in your ~/.emacs:"
+ elog ' (setq yc-server-host "localhost")'
elog
- elog "If you use inet domain socket for connecting the canna server, "
- elog " please modify as following in /etc/conf.d/canna."
- elog " CANNASERVER_OPTS=\"-inet\""
- elog " And create /etc/hosts.canna."
- elog " (see the sample.hosts.canna file in /usr/share/doc/${PF}/)"
-}
-
-pkg_postrm() {
- elisp-site-regen
+ elog "If you use inet domain socket for connecting the canna server,"
+ elog "please modify as following in ${EPREFIX}/etc/conf.d/canna:"
+ elog ' CANNASERVER_OPTS="-inet"'
+ elog
+ elog "And create ${EPREFIX}/etc/hosts.canna."
+ elog "See the sample.hosts.canna in ${EPREFIX}/usr/share/doc/${PF}."
}